LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI devices will not get recognized after computer sleep

Solved!
Go to solution

We have a NI PCIe-6351 and cDAQ-9189 (Ethernet) connected to the Windows 10 computer. I noticed that after the computer fall into sleep, some of the devices will not get recognized. Restart computer may not fix the problem. The computer main board is Fatal1ty, and processor is AMD A8-7600 Radeon R7. LabVIEW 18 and DAQmx 18 are installed. 

 

Thanks for any suggestions.

module detection1.png

0 Kudos
Message 1 of 6
(711 Views)
Highlighted

NI recommends disabling fast boot on your PC or the hardware may not perform as expected.  I suspect waking from sleep mode is a lot like a fast boot.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
Message 2 of 6
(633 Views)
Highlighted

@billko wrote:

NI recommends disabling fast boot on your PC or the hardware may not perform as expected.  I suspect waking from sleep mode is a lot like a fast boot.


It is called "fast startup" and every install of NI products will remind you. See point #2 here.

However, since a restart does not seem to fix the problem, the issue might be elsewhere.


LabVIEW Champion. It all comes together in GCentral GCentral
Message 3 of 6
(550 Views)
Highlighted

Thank Bill and altenbach for the replies. I have done three things related the fast boot/fast startup: 

1. Disabled fast boot from BIOS.

2. Unchecked the Turn on fast startup from power options.

3. Disabled fast startup from edit group policy.

I still have the same issue. The fix is to reset the cDAQ from NI-MAX, but the it will not survive another computer sleep.

0 Kudos
Message 4 of 6
(267 Views)
Highlighted
Solution
Accepted by topic author guangdew1

Try also to play with the "Power management" settings for the network adapter (using device manager) and also see if there is a newer driver available.


LabVIEW Champion. It all comes together in GCentral GCentral
Message 5 of 6
(252 Views)
Highlighted

altenbach, thanks for your suggestion. I disabled the network card power management from device manager, the cDAQ stays getting recognized after wake up from sleep. 

Message 6 of 6
(177 Views)