Showing results for 
Search instead for 
Did you mean: 

NI Vision Assistant - "Create LabVIEW VI" produces a blank VI

Hello, I'm using:

- LabVIEW 2011 SP1 v11.0.1 32bit

- Vision Assistant 2011 SP1 Build 20111212112331


When I create a simple script in Vision Assistant and click on "Create LabVIEW VI", the VI file is created, but when I open it, I can only see a blank VI.


I really hope someone could help me, I don't know how to solve this problem.


If you need more informations, I'll provide them.


Thank you!


0 Kudos
Message 1 of 15

Hi Beara, is this problem reproducible on other computer? Can you post your script that caused error?

Yupeng J.
0 Kudos
Message 2 of 15

Hi Yupeng J., first of all, thanks for your reply.


Unfortunately I've not a chance to test my script on other computers.


Anyway, the problem I reported happens for every script I create on Vision Assistant, no matter how simple they are. The same problem occurs even when I load any of the example scripts.


Later, I decided to create a blank VI, and I placed a "Vision Assistant" express VI in the block diagram. After having placed it, the "NI Vision Assistant" main window appeared. I loaded an example, named "Printed Circuit Board Inspection", then I clicked on "Finish". Then, the popup "Creating LabVIEW VI..." appeared for a few seconds, and after that an error prompt with the following message appeared: "There was an error in the process of creating the Express VI's code".


So, I think these two problems could be related in some way (generating LabVIEW code), but I really am not able to find a solution.


0 Kudos
Message 3 of 15



This problem seems to have appeared just as the 30 day evaluation on the regular NI Vision components installed with LV expired.

Is it your situation?

Could you chech your licenses expiration on NI License Manager?

You can find this software under the menu start->Program->National Instruments->NI License Manger.


The solution to this problem is to activate NI VDM permanently.




0 Kudos
Message 4 of 15

Hi, I installed the Vision Development Module only yesterday, and since then I haven't been able to generate the VI code.


I checked my license through "NI License Manager", and the following compoments are active (green square):


Vision Development Module 2011 SP1:

- Full (Vision Debug Deployment+Vision Development)

- Vision Run-Time


So, the licenses seems to be active, but the problem still occurs.


0 Kudos
Message 5 of 15



You observe this behaviour with other Express VIs? Or only using Vision Assistant  Express VI?

If this so, I suggest you to repair Vision Development Module.


Let me know



0 Kudos
Message 6 of 15

Hi Claudio, I added the following Express VI in a blank block diagram, like you suggested:

"Prompt User for Input"

"Vision Acquisition"

No error messages appeared after having placed them in the block diagram, or after their configuration.

However, if I place a "Vision Assistant" Express VI, I still receive the following message error after having configured it:

"There was an error in the process of creating the Express VI's code"


Moreover, I tried to repair the following modules, in sequence:

NI Vision Common Resources 2011 SP1 f1

NI Vision Assistant 2011 SP1

NI Vision 2011 SP1

For each of the 3 reparations, I had to reboot the PC. However, the problem hasn't disappeared, I'm still unable to generate a VI by using Vision Assistant.


I really hope to solve this annoying problem, because the day of my exam is getting closer... so suggestions are more than appreciated, at this point I don't know how I could fix that.


In attachment you can find a simple Vision Assistant script, and the blank VI produced. Please note that Vision Assistant always produces a blank VI, no matter of the script, like I stated earlier.


A final note, I tried to generate C and .NET code for the script in attachment while using Vision Assistant, and it seemed to work (no message errors or blank C/.NET files produced), so this is a problem related to LabVIEW code generation only.


0 Kudos
Message 7 of 15

I reinstalled everything from scratch, but the problem still occurs.


0 Kudos
Message 8 of 15


0 Kudos
Message 9 of 15

Ok, here is what I did:


1) I uninstalled everything (LabVIEW 2011 SP1, Development Module 2011 SP1, ...).
2) I installed LabVIEW 2011 (not with SP1).
3) I installed the latest Device Drivers dated March 2012 (NI-IMAQdx,...).
4) I installed Vision Development Module 2011 (not SP1).


I tried to generate a VI using Vision Assitant, but the problem is still there: Vision Assistant produces a blank VI.

I still encounter the same problem even when I place a Vision Assistant Express VI in the block diagram: when I create a simple Vision Assistant script and I click on finish, the same error message appears ("There was an error in the process of creating the Express VI's code").

This is a LabVIEW bug, what could be the solution? I really don't know where to start to fix this.


0 Kudos
Message 10 of 15