LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI-VISA (no access permission)

Solved!
Go to solution

Hi,

I have 5 systems running one version of labview software and all but 1 is working properly.

the one that is not is having a memory leak.

This one also have (NI-ViSA with no access permission) icon on the lower right hand corner.

All the others does not say so.

I am very sure it got to do with NI-VISA but i have tried upgrading NI-VISA and that didnt solved the problem.

Can someone guide me on fixing this?

thanks

 

Best regards,
Krispiekream
0 Kudos
Message 1 of 12
(1,667 Views)

Can you post a screenshot of the icon?

 

It sounds like a firewall or user permissions problem.

0 Kudos
Message 2 of 12
(1,657 Views)

here you go

Best regards,
Krispiekream
0 Kudos
Message 3 of 12
(1,651 Views)

Are the user accounts on the all of the computers set up in the same way?

 

Are the firewalls set up the same?

0 Kudos
Message 4 of 12
(1,642 Views)

yeah. all accounts uses 1 login and 1 password for all system.

all firewalls are the same.

 

Best regards,
Krispiekream
0 Kudos
Message 5 of 12
(1,631 Views)

I'm pretty well stumped.

 

Maybe this from the VISA User Manual helps:

 

How to Configure and Use Remote NI-VISA
On the server machine (the one to which the hardware is connected), you
must install Remote NI-VISA Server. This installation optionmay not exist
in all NI-VISA distributions. By default, the server is disabled and access
from any other computer is disallowed. Use the NI-VISA configuration
utility (MAX onWindows, visaconf on UNIX) and make sure the server
is enabled. You must also specify each address or address range of the
computer(s) you wish to allow access. An address can be either in dot
notation (x.x.x.x) or the network machine name; an address range can only
be in dot notation (x.x.x.*).
On the client machine, no configuration is necessary. The VISA resource
string contains the server machine name and the original VISA resource
string on the server: "visa://hostname/VISA resource string".
The hostname can be represented as either an IP address (dot-notation) or
network machine name.
If you want to search for all resources on a specific server, you can pass
"visa://hostname/?*" to viFindRsrc(). On Windows, you can use
the “Remote Servers” section of MAX to configure NI-VISA to access
certain servers by default. In this case, using "?*" will cause
viFindRsrc() to query all configured servers as well as the local
machine. If you want to limit the query to the localmachine only, regardless
of whether it has been configured to access any remote servers, pass "/?*"
as the expression to viFindRsrc().
Remote NI-VISA supports the complete functionality of all attributes,
events, and operations for all supported hardware interface types.

0 Kudos
Message 6 of 12
(1,613 Views)

thanks for your help. i am still working on finding out whats wrong.

the reason why i brought up the no access permissions by NI-VISA because its the only thing that i see differently between the systems.

could it be the version of visa?

all the other uses ni-visa 3.3 and this one uses 5.0?

Best regards,
Krispiekream
0 Kudos
Message 7 of 12
(1,610 Views)

I think it would definitely be worth downgrading and seeing if that fixes the issue on the problem computer.

0 Kudos
Message 8 of 12
(1,598 Views)

untitled.PNG

Best regards,
Krispiekream
0 Kudos
Message 9 of 12
(1,586 Views)

how do i downgrade this again?

I completely forgot how to do this.

 

Best regards,
Krispiekream
0 Kudos
Message 10 of 12
(1,584 Views)