LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI VISA driver problem

hello everyone, 

I'm new to labview (i have Labview 2019) and I'm working on small project which is reading holding register program of a PID regulateur using modbus library throught serial connection RS485, in order to establishe the connection I'm told I need to install NI-VISA driver from the officiel website which i did, however when i try to execut it i get an error message, i dont know whats the problem seem to be i have tried everything including using windows commend prompt to force the reinstall still it didnt work; I'm hoping you guys can help me.

i have attached an image of it 

0 Kudos
Message 1 of 7
(241 Views)

My French isn't great but it looks like you have a standard download failure when the installer was trying to get the VISA dotNET components.  I assume you tried a few times.  Are you sure you have admin permissions to install software?  You can go to your download folder and right-click on the VISA exe and there should be an option for "Run as Administrator".  That may elevate your privileges so you can install or it may ask for an admin password.  If you don't have one you'll have to ask whoever set up your PC to give you admin rights while you do your install.

LabVIEW Pro & Measurement Studio Pro (VS Pro) 2019
0 Kudos
Message 2 of 7
(189 Views)

hey there thanks for replaying ; I tried what you suggested and sadly it didnt work i get 2 errors messages saying that the product NI-VISA is not found even thought its already installed.

i have attached a picture below.

Download All
0 Kudos
Message 3 of 7
(158 Views)

First off, it's not a good idea to mark a solution if you haven't solved your problem yet. 

Other posters that could help may ignore this thread thinking it's done. 😉

 

You should have NI-MAX installed.  Run it and post an image of the Software tab.  Mine looks like this:

NI-Max Software.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You should have NI-VISA 20 if you got it recently.  It should work fine with LabVIEW 2019.  If that is there then I suggest you also install NI-Serial 20.  I have found that sometimes LabVIEW complains about missing VISA components when it already has them an actually needs something from NI-Serial or NI-488.2 (GPIB).  I usually install them all on any PC I plan to run LabVIEW code on.  You can get them here:

 

NI-Serial Download - NI

NI-488.2 Download - NI

LabVIEW Pro & Measurement Studio Pro (VS Pro) 2019
0 Kudos
Message 4 of 7
(125 Views)

hi there, actually i accedantly touched the solution button without knowing hhh i guess labview is getting to my head.

so already installed those drivers same problem the product is not found 

i have attached a picture of ni max below .any other ideas i should try?

0 Kudos
Message 5 of 7
(97 Views)

hi there, actually i accedantly touched the solution button without knowing hhh i guess labview is getting to my head.

so I already installed those drivers same problem the product is not found 

i have attached a picture of ni max below .any other ideas i should try?

0 Kudos
Message 6 of 7
(96 Views)

It looks like you have everything properly installed as far as LabVIEW is concerned.  I put the error code in on the ni.com/info site and it provided a list of possible issues:

 

Problem Updating Feeds When Installing Through NI Package Manager - National Instruments

 

Almost all of them are problems with downloading into the Package Manager.  Things like your firewall settings, anti-virus, VPNs, etc.  Have you looked at that list?  Are you working for a company that has an IT department that might help?

LabVIEW Pro & Measurement Studio Pro (VS Pro) 2019
0 Kudos
Message 7 of 7
(61 Views)