Showing results for 
Search instead for 
Did you mean: 

NI-VISA Error -1073807246 (0xBFFF0072) the Resource Is Valid but, VISA Cannot Currently Access It

I tried every solution given in this but still couldn't solve this. Please help.
As described above in the subject line, I am not able to use LabVIEW and Arduino interface to run XBee X2C pro in order to fetch the data of temperature and humidity. 
I have followed step by step instructions from your support website but still not able to find solution.
It is showing an error (NI-VISA Error -1073807246 (0xBFFF0072) the Resource Is Valid but, VISA Cannot Currently Access It - NI).
Please provide help for the same.
0 Kudos
Message 1 of 3

Please provide more information on the Arduino, its firmware, how it is connected to XBee X2C pro and the LabVIEW code too.

Soliton Technologies

New to the forum? Please read community guidelines and how to ask smart questions

Only two ways to appreciate someone who spent their free time to reply/answer your question - give them Kudos or mark their reply as the answer/solution.

Finding it hard to source NI hardware? Try NI Trading Post
0 Kudos
Message 2 of 3

Usually that error means another program either has control over the VISA resource (Com port in your case) or is not properly releasing the resource when it exits.


Make sure the Arduino IDE or serial monitor still running while trying to use LabVIEW.


I have seen cases where an Arduino shows up as two different Com ports in Windows, but only one works. 

=== Engineer Ambiguously ===
0 Kudos
Message 3 of 3