LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI-VISA Driver Wizard is missing from my computer?

Solved!
Go to solution
Highlighted

Hello,

 

I am using LabVIEW 2014 and 2015.

I want to create a driver for a Zebra printer uising the NI-VISA Driver Wizard, but it is apparantly missing from my PC.

My co-worker has it, but I do not.

What do I download and re-install to correct this issue?

 

The folder it should be in, I think is: C:\Program Files (x86)\IVI Foundation\VISA\WinNT\NIvisa

Veni Vidi Duci
0 Kudos
Message 1 of 11
(4,571 Views)

Do you have the full NI-VISA install or just the runtime?

 

Here is the full install: http://www.ni.com/download/ni-visa-15.0.1/5693/en/

Kenny

0 Kudos
Message 2 of 11
(4,529 Views)

I downloaded the full version yesterday, I am pretty sure I installed it yesterday. I will run it again to be sure.

I also tried to install the IVI foundation and the VISA runtime.

Ultimately I used my co-workers version to create the drivers, but I don't understand where the driver wizard would have gone.

 

Edit:

When I run the program, it pretty much tells me that it cannot install much since it's already installed.

Veni Vidi Duci
0 Kudos
Message 3 of 11
(4,525 Views)

I am guessing probably you forgot to install it (it happens).

 

See this thread, where something similar happened: http://forums.ni.com/t5/Instrument-Control-GPIB-Serial/How-to-start-NI-VISA-Driver-Development-Wizar...

Kenny

0 Kudos
Message 4 of 11
(4,521 Views)
Solution
Accepted by JÞB

Well, I downloaded the 15.0.1. I used 15.0 yesterday.

Anyway, I get the same issue where it says the feature is installed and will not install it. I suppose I just have to uninstall first before re-installing. I will try that later tonight.

1.png

2.png

Veni Vidi Duci
Message 5 of 11
(4,515 Views)

I would do a repair install first before doing a full uninstall/reinstall.  You do that through the Control Panel > Programs and Features.  Locate the National Instruments entry and click 'Unistall/Change' and then select NI VISA X.X.X (where the X.X.X is probably 15.0.0 in your case), and then press 'Repair'.

Kenny

0 Kudos
Message 6 of 11
(4,511 Views)

I tried a repair. That didn't work.

 

The program is located in the IVI Foundation folder, C:\Program Files (x86)\IVI Foundation\VISA\WinNT\NIvisa, correct?

There is also no link to it in my start menu.

Veni Vidi Duci
0 Kudos
Message 7 of 11
(4,500 Views)

Not as if I actually knew anything but ...

 

This couldn't be a Windows 10 issue could it?

 

Just ignore me if it not Windows 10.

 

Ben

0 Kudos
Message 8 of 11
(4,485 Views)

@Ben wrote:

Not as if I actually knew anything but ...

 

This couldn't be a Windows 10 issue could it?

 

Just ignore me if it not Windows 10.

 

Ben


No sir, Windows 7.

 

I plan to do a clean install before the end of the weekend when I have more time.

If that doesn't work, then something is seriously wrong.

Plus, all the notes I see about the program is it is located in Start>Programs>National Instruments>VISA

Not to nitpick, but I have no such folder and I would assume it would be in NI-VISA.

Veni Vidi Duci
0 Kudos
Message 9 of 11
(4,463 Views)
Solution
Accepted by topic author DB_IQ

After working with tech support, we added the driver wizard by going using the install repair to add the driver wizard in NI Visa 16.0.0

Odd, that, since I did that before.

But it's ok. It works now. So this one is closed. Thanks.

Veni Vidi Duci
0 Kudos
Message 10 of 11
(4,053 Views)