LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI-USRP RIO FPGA Rebuild needed without changes

Solved!
Go to solution

Hello,

 

I'm trying to get into using our USRP RIOs NI-2943R with LabVIEW Comms 2.0.

I started with the Example USRP RIO 120-160 Mhz Multi Device Streaming that comes with the NI-USRP.

 

Opening the example and running it works perfectly fine.

Then after stopping it, no changes are made, just hitting the run button directly again LabVIEW tells me the FPGA Code is not up to date and has to be rebuild.

After rebuilding it, the VI runs ones and then same Message comes, still no changes made. Not even a Parameter adjusted.

 

Rebuilding takes roughly 1 hour so right now this kills any kind of workflow.

 

Is this working as intended ?

 

Setup is PXIe-8133 controller running Windows 7. All LabVIEW stuff up to date. NI-2943R connected over PXI Hub.

0 Kudos
Message 1 of 3
(1,159 Views)

Hi,

 

surely if there is really no change that is a misbehaviour on LV Comms's side.

But why don't you just run the already existing bitfile when opening a FPGA reference. That bitfile has to be up to date since nothing changed?!

 

Best regards,

Christoph

Staff Applications Engineer
National Instruments
Certified LabVIEW Developer (CLD), Certified LabVIEW Embedded Systems Developer (CLED)


Don't forget Kudos for Good Answers, and Mark a solution if your problem is solved
0 Kudos
Message 2 of 3
(1,105 Views)
Solution
Accepted by topic author Kevin-R.

Found the Solution.

 

The FPGA Image on the Device seems to get corrupted when you abort the program with the red Button. Powercycling the USRPs fixes the Error.

 

To prevent it all together, program and use stop button so the Code exits by it self.

0 Kudos
Message 3 of 3
(1,095 Views)