Showing results for 
Search instead for 
Did you mean: 

NI USB-6001 recognised by Device Manager and NI Max but not cannot create tasks

I have USB-6001 that I used a few versions of LabVIEW ago (no longer installed). My current Windows laptop has LabVIEW 2022 Q3 installed and I am trying to create a simple application to use the USB-6001.


When I plug the DAQ device in, it appears in both the Windows Device Manager and NI Max



but this is all I appear to be able to do with it.



When I try to create a new task for anything, I get this:



Any clues?


0 Kudos
Message 1 of 8

DAQmx is installed? Try to reinstall it first.


0 Kudos
Message 2 of 8

I thought so! I have all the DAQmx stuff in the functions menu:



And if I run the NI_DAQmx installer I get this.




0 Kudos
Message 3 of 8

As I recall (when it happened to me maybe a decade ago), when a DAQ device such as a USB-6001 shows up in MAX as something other than "dev1" (or some other number), but as USB\VID_nnnnnn, that is a sign that the driver is missing, so DAQmx can't "do its thing" and handle it as a "dev"ice.


How to fix this?  In my earlier LabVIEW experiences (in the early 20-teens), I (once or twice) tried to "repair" a LabVIEW installation (such as "DAQmx").  This procedure typically took many tens of minutes, sometimes hours.  Much faster was to uninstall LabVIEW (all versions, which, at the time, was usually 2 or 3) and re-install (took a few tens of minutes).  The same is probably what I'd do today, as well.


Before you do, however, please supply some additional information:

  1. What version(s) of LabVIEW are you running?  Give "year designation" and whether 32- or 64-bit.
  2. Who did the installation?
  3. Open MAX, expand the Software tab, and send us a screen-shot that shows what components of MAX are present.  Maybe something is missing ...

Bob Schor

0 Kudos
Message 4 of 8

Ah - well .. I have already embarked on a 'repair' of - what I thought was DAQmx only, however, maybe I didn't deselect things and it is, as you say, taking ages. Now I don't know if it's wise to stop it as I might end up with a partially repaired system.

One thing to note is that I also installed the community edition to use for my own projects rather than my consultancy stuff - so it's possible that has complicated things!

I am running LabView 2022 Q3 32-bit. Although it quotes my correct paid-for serial number, it now also says 'community edition' on the About screen. I think this is a bug and that only appeared since I installed the community edition.

The community edition is 2024.

I did the installation - I am the owner and administrator of this computer.


This the screenshot of the MAX software tab:




For some reason, MAX makes the text tiny - I can't tell how legible it is until I post this answer - it looks fuzzy in this preview.



0 Kudos
Message 5 of 8

You have DAQmx 22.5, try to update to the latest version 2024Q2, should be compatible with previous version.

Could be interference with Community Edition, but pretty sure, I have had similar "combination" and LabVIEW Professional installed side by side was functional with USB I/O. 

0 Kudos
Message 6 of 8

OK Andrey , I will try the latest DAQmx if this current repair doesn't work; I didn't want to install that and find it broke my LV 2202 Q3.

0 Kudos
Message 7 of 8

@magicbean wrote:

OK Andrey , I will try the latest DAQmx if this current repair doesn't work; I didn't want to install that and find it broke my LV 2202 Q3.

Hopefully will be not broken. Here is NI-DAQmx and LabVIEW Compatibility Table, but as usually NI do not track very recent versions , so we can just "propagate" this to the latest version.

Anyway, DAQmx 2023 Q3 is officially compatible with your 2022 Q3:

Screenshot 2024-05-03 17.30.28.png

0 Kudos
Message 8 of 8