LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI TC-01 stops working

I have written some Labview code that take 1 reading every second from the TC-01.
It works on my PC and other PC's abroad but it stops working, on a specific PC after a couple of hours.
The error message is:
 
     9/14/2016 3:23 PM -201003 DAQmx Read (Analog DBL 1Chan 1Samp).vi:1<append>
          <B>Task Name: </B>_unnamedTask<0>
 
Error -201003 is
 
     Device cannot be accessed. Possible causes:
     Device is no longer present in the system  /  Device is not powered  /  
     Device is powered, but was temporarily without power  /  Device is damaged
 
I have a separate tasks which read a signal from a potentiometer at a sample rate of 720 samples a second.
 
I have got them to go into 'Device Manager' and make sure that the USB devices don't turn off.
The TC-01 is connected directly to a desktop PC.
 
I have been looking at the NI site for help but can't find the answer.
 
I have noticed that you can 'Reset Device', do you think that will help?
 
I really need to solve this.
 
Thanks
TimS
 
0 Kudos
Message 1 of 8
(1,527 Views)
It is a USB device so I suspect that for some reason, the connection to the device gets lost. Do you try to re-establish the connection to the device if it fails or do you only ever initialise once at the start of your application?

I don't consider USB to be a 'robust' communications standard - someone plugging in another device, or there being lots of bus traffic, could cause devices to drop out.

LabVIEW Champion, CLA, CLED, CTD
MediaMongrels Ltd. - NI Alliance Partner (blog)
0 Kudos
Message 2 of 8
(1,522 Views)

Check the power management options for that PC to see if it is disabling the USB ports after awhile as an energy saving "feature".

0 Kudos
Message 3 of 8
(1,517 Views)
Thanks for the quick response.
 
It is a USB device and at the moment I just report the error but was thinking of trying to re-establish communication.
How would I got about doing that, I am looking at the 'Reset Device' option but it is asking for a device and not a task.

 

 

0 Kudos
Message 4 of 8
(1,513 Views)

Thanks but I have tried that but it doesn't seem to stop the TC-01 not working after a certain time.

I have even got them to disable the screen saver.

 

 

0 Kudos
Message 5 of 8
(1,511 Views)

Windows Control Panel >> Power Options

0 Kudos
Message 6 of 8
(1,509 Views)

@TC_Magic wrote:
How would I got about doing that, I am looking at the 'Reset Device' option but it is asking for a device and not a task.

 


Just clear the DAQmx task and re-initialise it.

 

If you use Reset Device, you can get the device from the task by using a 'DAQmx Task' property node. It will return an array containing all of the devices used in the task which you can then reset in a For loop (or index out the first element since it will be the only device in your task).


LabVIEW Champion, CLA, CLED, CTD
MediaMongrels Ltd. - NI Alliance Partner (blog)
0 Kudos
Message 7 of 8
(1,479 Views)

Thanks.

I will try it and let you know how I get on

 

0 Kudos
Message 8 of 8
(1,474 Views)