LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI ServiceLocator is not running on OS X

I've tried stopping and restarting the help server, turning the firewall on and off, and explicitly allowing niLxiDiscovery.app in the firewall list, and rebooting, but I still get the same error. Perhaps you have a mac at NI where you can give this a try?

 

There is no file with a name anything like ServiceLocator.llb on my machine.

 

Thanks,

-Scott

0 Kudos
Message 11 of 29
(1,396 Views)

Hi Scott,

 

We do have a Mac here, but unfortunately, while it is an issue for a lot of customers, it is not always reproduceable and with that being said, I did try this out a while ago and was able to get into the Example Finder.  I don't immediately have access to the Mac, but based on this Knowledge Base, the NI Service Locator was lumped with the NI System Web Server in LabVIEW 2010.  Granted this KnowledgeBase is for Windows, the existance of the Web Server is the same for MAC.  The issue I am running into right now is how to stop and start the Web Server on Mac.  Do you have a Web Server at this location: labview\resource\system.  If you do, please run the VI and click the STOP button to toggle between enabling or disabling the Web Server. I hope this helps!

 

Kim

Applications Engineer
National Instruments
0 Kudos
Message 12 of 29
(1,391 Views)

I am also having the exact issue the others have listed here.  I'm running Mac OS X Version 10.6.7, Labview 2010 SP1.  I also only have the "HelpServer.llb" in my system directory.  The files I have related to "server" and "web" are:

webdoc.llb

webrsrc.llb

HelpServer.llb

LaunchServices.llb

server.llb

ServLocinterface.llb

 

Thanks,

0 Kudos
Message 13 of 29
(1,370 Views)

I played with running and restarting the HelpServer vi. It doens't fix the issue. It's the Service Locator that's missing.

 

I too can get into the example finder. I can even browse examples, I just can't open any of the examples once I drill down to a specific one.

 

I took a look at ServLocInterface.llb, but nothing there seems to be a top level vi to start the service locator. Running SL_is Service Locator Running.vi returns false (as expected?).

 

Perhaps you can elevate this bug up the chain? Installing a clean version of 2010sp1 onto a mac at NI ought to reproduce the issue.

 

It's very frustrating when such a basic functionality doesn't work.

 

Thanks,

-Scott

0 Kudos
Message 14 of 29
(1,366 Views)

I took a look at all the .llb files you listed. Nothing seems to be apropos to this issue.

 

NI: Help!

0 Kudos
Message 15 of 29
(1,360 Views)
Kim

You mention that you can get into the Example Finder.
This is not the issue - opening a file/example from the list of examples causes the error.
Neil
0 Kudos
Message 16 of 29
(1,355 Views)

Hi neilhu,

 

I apologize for the confusion.  I was able to also open examples, not just the Example Finder.

 

Here are a few other steps to try:

 

First, to manually verify if the Service Locator is running or not, open the application located in \Applications\Utilities\Activity Monitor.  Then, in the top right hand corner, change the drop down selection box to "All Processes".  This will now show all running programs on the machine.  You can now filter out everything we don't care about by typing "ni" (note the lower case) in the search box in the top right hand corner of the Activity Monitor window.  This will then show a short list of processes.  If Service Locator is running, you should see nisvcloc in the list.

 

If nisvcloc isn't showing up, the next step I would take would be to try and manually run the nisvcloc program.  You can do this using the application located in \Applications\Utilities\Terminal.  This will open up a command prompt on the machine.  Once you are at the command prompt, run the following command to start service locator:

     /Library/Application\ Support/National\ Instruments/Service\ Locator/nisvcloc &

Once you have run the command above, re-open LabVIEW 2010 and try the example finder again.

 

If starting the nisvcloc manually from Terminal works but it seems that the service locator isn't automatically starting, we can check the LauchDaemon script to ensure it is configured properly on disk.  To do this, open Terminal again and execute the following two commands:

     cd /Library/LaunchDaemons/

     ls -la

This will change your terminal session to the directory where the NI Service Locator script lives.  It will then list the directory contents along with some permissions.  The Service Locator script line will probably look something like this:

     -rw-r-xr-x   1 root  wheel   490 Jan  9  2010 com.ni.ServiceLocator.plist

What this tells us is that the permissions are 0655, the file is owned by root and the group wheel, it is 490 bytes, was last modified on Jan 9, and is named com.ni.ServiceLocator.plist.  One potential problem that I have seen cause issues in the past is the file permissions.  Sometimes this file appears to get 0655 permissions instead of 0644 which is slightly more restrictive and what OS X actually seems happy with.  If the permissons on your file do look the same as the example above (-rw-r-xr-x) then you can try changing them by running this command:

     sudo chmod 644 /Library/LaunchDaemons/com.ni.ServiceLocator.plist

This command will prompt the user for their password as the "sudo" command is basically the same as doing "Run as Administrator" on Windows.  This is necessary to change the permissions on this particular file.  Once the permissions are changed using the chmod command, reboot and theoretically the Service Locator should load (you can verify this using the Activity Monitor suggestion from earlier in this post). I hope this helps!

 

Kim

Applications Engineer
National Instruments
0 Kudos
Message 17 of 29
(1,338 Views)

1. nisvcloc isn't running.

2. I tried to issue the command you gave. Here is the error message:

 

/Library/Application Support/National Instruments/Service Locator/nisvcloc: No such file or directory

 

3. Looking more closely, there is no directory called Service. Take a look:

 

pwd

 

/Library/Application Support/National Instruments

 

ls

 

Errors

NI-VISA

nipal

NI Spy

example finder

nirpc

 

4. There is no Service directory and I've been unable to find nisvcloc on my machine. It looks like it is not getting installed.

 

Thanks,

-Scott

 

 

 

0 Kudos
Message 18 of 29
(1,333 Views)

Same here.

 

No nisvcloc file

No launch daemon

0 Kudos
Message 19 of 29
(1,326 Views)

Hey Everyone,

Do you see the nilxid.plist in your Launch Daemons?  I think that after 2010 the nisvcloc will not show up in your activity monitor since it has been bundled into the Web Services.  The only way you will see those folders is if you have older versions of LabVIEW installed (2009 or earlier).  I am currently working on getting a machine up and trying to reproduce the issue you are having.

 

 

Kevin Fort
Principal Software Engineer
NI
0 Kudos
Message 20 of 29
(1,299 Views)