LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI RIO installation error for windows 8 Labview 2016

I wish to interface my windows-8 laptop with NI 9205 via NI c-DAQ 9172. In the process I got the correct driver which reads 9172, but it does not read NI 9205, NI 9263, NI 9401 modules which are already attached.  So, I saw that first you install NI RIO and then update it with  NI RIO210f1 to make ot work. When I try to instal NI RIO, I get the error

 

The windows installer engine is corrupt. To attempt to resolve this issue, please register the engine by running regsvr32.exe or mki.dll .

What is the problem and how do I proceed.

Does NI 9205 work with windows 8?? 

0 Kudos
Message 1 of 4
(1,485 Views)

Hello Anuj_Kuruwa,

 

for a cDAQ 9172 you need the NI-DAQmx driver, this driver should support the moduls and chassi. The NI-RIO driver is needed, if you work with  our Real Time targets like cRIO 9039 and so on.

 

What LabVIEW Version do you want to use?

best regards
Alexander
0 Kudos
Message 2 of 4
(1,478 Views)

I had installed the NI-daq15.1 version and Labview is reading NI daq 9172 but not the module of interest which is NI 9205 and NI 9263. When I tried to install the NI-daq1610f3 it shows the following error- The application was unable to start correctly (0xc0000018). And I still don't know the source of NI RIO error even if I am not using a real time module.

0 Kudos
Message 3 of 4
(1,442 Views)

Hello Anuj_Kuruwa,

can you try this

Errror 0xc0000018 when running DAQmx 16 on Windows 10

  1. Press Win+R and type regedit
  2. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\­Microsoft\WindowsNT\CurrentVersion\Windo­­ws
  3. Than search for APPINIT_DLLS and delete the default value
  4. Reboot
best regards
Alexander
0 Kudos
Message 4 of 4
(1,438 Views)