LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI-RIO driver crashed

Hi to all,

I'm using FPGA Interface C API Generator 15.0 for my C++ application.

Sometimes I get the error mentioned in the attachment.

Do you have any idea?

 

Thanks in advance 

Giovanni Maio

0 Kudos
Message 1 of 5
(879 Views)

To  show us an Error without providing the Context (like "What were you doing when the Error occurred?", or "Why do you think it only occurs sometimes?" or "Show us the code you are trying to run", or "What is the code supposed to be doing?" or "What resources are being used?", or "What version(s) of the Software are you using?"), I would say that you have an "occasional error".  Have you reported the Error to NI?  It looks like it may be a failure in one of their underlying support/run time/code generation routines (can't tell which to suspect, as we don't know the context), and if they've seen this before, they may have a work-around.

 

Bob Schor  

0 Kudos
Message 2 of 5
(838 Views)

Dear Bob,

Here's more details about the context.

We use 4 NI PXIe-7971R, 1 NI PXIe-7975R, and a SMBus Controller with drivers in version 15.5.0.49152.

The FPGAs are driven by a C++ application, the whole being hosted on a Windows Server 2012 R2?

The problem we are reporting occurs on the NI PXIe-7975R FPGA while running a bitfile implementing parallel processing on 3 different channels.

We have no problem when we process on one of the 3 channels, but the Windows server crashes after a few minutes when we process on several channels at the same time.

The NI Update Service on the Windows server suggests to install the following updates but we are not sure if it's necessary, and if it won't lead us to any compatibility issue with our bitfiles.

NI Update Service
================================================================================
LabVIEW Run-Time Engine 2014 SP1 (32-bit) f11 Patch
299 MB
An update is available for the LabVIEW 2014 SP1 Run-Time Engine that fixes a critical issue. This update is strongly recommended for all users of the LabVIEW 2014 SP1 Run-Time Engine. To obtain more information, click the following link or visit ni.com/info and enter the Info Code: LV2014SP1PatchKB_en.
http://digital.ni.com/express.nsf/bycode/LV2014SP1PatchKB_en
--------------------------------------------------------------------------------
LabVIEW Run-Time Engine 2014 SP1 (64-bit) f11 Patch
286 MB
An update is available for the LabVIEW 2014 SP1 Run-Time Engine that fixes a critical issue. This update is strongly recommended for all users of the LabVIEW 2014 SP1 Run-Time Engine. To obtain more information, click the following link or visit ni.com/info and enter the Info Code: LV2014SP1PatchKB_en.
http://digital.ni.com/express.nsf/bycode/LV2014SP1PatchKB_en
--------------------------------------------------------------------------------
LabVIEW Run-Time Engine 2015 SP1 (32-bit) f10 Patch
304 MB
An update is available for the LabVIEW 2015 SP1 Run-Time Engine that fixes multiple critical issues. This update is strongly recommended for all users of the LabVIEW 2015 SP1 Run-Time Engine. To obtain more information, click the following link or visit ni.com/info and enter the Info Code: LV2015SP1PatchKB_en.
http://digital.ni.com/express.nsf/bycode/LV2015SP1PatchKB_en
--------------------------------------------------------------------------------
LabVIEW Run-Time Engine 2015 SP1 (64-bit) f10 Patch
293 MB
An update is available for the LabVIEW 2015 SP1 Run-Time Engine that fixes multiple critical issues. This update is strongly recommended for all users of the LabVIEW 2015 SP1 Run-Time Engine. To obtain more information, click the following link or visit ni.com/info and enter the Info Code: LV2015SP1PatchKB_en.
http://digital.ni.com/express.nsf/bycode/LV2015SP1PatchKB_en
--------------------------------------------------------------------------------
National Instruments Distribution of Microsoft Silverlight (2016 Q2)
42 MB
An update is available for National Instruments' distribution of Microsoft Silverlight that addresses a security vulnerability that could allow remote code execution. This update is strongly recommended for all users. To obtain more information, click the following link or visit ni.com/info and enter the Info Code: NIMSSL2016Q2
http://digital.ni.com/express.nsf/bycode/NIMSSL2016Q2
--------------------------------------------------------------------------------
NI Core Driver Update - 2017 Q2 Patch
70 MB
An update is available for a core component of multiple NI drivers. The update fixes a known issue in which LabVIEW may crash upon exit after usage of a Terminal I/O Control. This update is strongly recommended for all LabVIEW users interacting with NI hardware. To obtain more information, click the following link or visit ni.com/info and enter the Info Code: CoreDriverUpdate2017Q2
http://digital.ni.com/express.nsf/bycode/CoreDriverUpdate2017Q2
--------------------------------------------------------------------------------
NI Vision Common Resources (2016 Q4)
93 MB
An update is available for Vision Common Resources that fixes multiple issues. This update applies to all versions up through 2016 and is strongly recommended for all users of vision software products. To obtain more information, click the following link or visit ni.com/info and enter the Info Code: vision2016Q4patch
http://digital.ni.com/express.nsf/bycode/vision2016Q4patch
--------------------------------------------------------------------------------
NI-DAQmx 15.5.1 -- Patch for NI cDAQ-9179
1,761 MB
An update is available for NI-DAQmx versions 15.1.0 and later that addresses an issue in which incorrect data is returned by multi-device tasks run on the NI cDAQ-9179 chassis with specific module configurations. This update is strongly recommended for all NI cDAQ-9179 users. To obtain more information, click the following link or visit ni.com/info and enter the Info Code: daqmx1551_en
http://digital.ni.com/express.nsf/bycode/daqmx1551_en
--------------------------------------------------------------------------------
NI-DAQmx 17.1.1 -- Patch for CompactDAQ NI-XNET users
1,423 MB
An update is available for NI-DAQmx 15.1 through 17.1 that fixes multiple critical issues. This update is strongly recommended for all users of CompactDAQ with NI-XNET applications. To obtain more information, click the following link or visit ni.com/info and enter the Info Code: DAQmx1711.
http://digital.ni.com/express.nsf/bycode/DAQmx1711
--------------------------------------------------------------------------------
NI-DAQmx Configuration Runtime 16.0.1 -- Patch for NI 9361 and NI 9469 Users
1,335 MB
An update is available for NI-DAQmx 14.5 up through 16.0 that fixes multiple critical issues for the NI 9361 and NI 9469. This update is strongly recommended for all NI 9361 and NI 9469 users. To obtain more information, click the following link or visit ni.com/info and enter the Info Code: daqmx1601
http://digital.ni.com/express.nsf/bycode/daqmx1601
--------------------------------------------------------------------------------
NI Core Driver Update - 2016 Q3 Patch
92 MB
An update is available for a core component of multiple NI drivers. The update fixes an error when using MAX test panels or the DAQ Assistant with devices on real-time targets. This update is recommended for users of real-time targets. To obtain more information, click the following link or visit ni.com/info and enter the Info Code: CoreDriverUpdate2016Q3_en
http://digital.ni.com/express.nsf/bycode/CoreDriverUpdate2016Q3_en
--------------------------------------------------------------------------------
================================================================================

0 Kudos
Message 3 of 5
(829 Views)

Dear Giovanni,

 

     Am I correct that everything is running on a PC running Windows Server 2012 R2?  What version of LabVIEW are you running?  [I'm guessing it is 2015, since you mention Drivers that seem to be from that Version].  Are you running 32-bit LabVIEW (on a 64-bit OS, of course) or 64-bit LabVIEW?  I don't know all of the NI hardware to which you refer -- can you give me a brief description of all of the "boxes" and major NI Software Components you are using?  [I'm trying to understand if you are running LabVIEW Real-Time, with the Host being Windows Server and the Remote(s?) being PXI boxes].

 

     If things are working (and they are not, it sounds like),  you can consider updating, but I would urge caution in applying updates that either (a) are for versions newer than what you are running, (b) for hardware or software components you do not have installed, or (c) for 64-bit components if you are running 32-bit LabVIEW.

 

Bob Schor

 

 

0 Kudos
Message 4 of 5
(809 Views)

I'm using 32-bit Labview 2015. it is useless to say that the 64-bit Labview 2015 is not stable enough as a fpga development environment. I use labview only to compile the bitfiles. The application is written in C ++ and uses the APIs created by the generator. The system is typical, data entry on DMA, processing on FPGA and reading of data from DMA.

 

Thanks

Giovanni Maio

0 Kudos
Message 5 of 5
(800 Views)