LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI MXS 18.5.0 installation has failed

Solved!
Go to solution

Picture2.png

 

I have reoccuring problems installing various versions of DAQmx 18.5, 18.6, 19 etc, I always end up with this error message at some instance,

stopping and destroying the installation. What is this for hopeless installation system, and how can I solve this ?

Martin

0 Kudos
Message 1 of 5
(1,032 Views)
Solution
Accepted by topic author MartinP

Several people (including me) have had trouble installing the most recent versions of LabVIEW.  In my experience, once it "goes awry", you need to first uninstall all NI Software from your PC (instructions for how to do this safely can be found on the Web and on this Forum), and then start carefully and slowly to install the version(s) of LabVIEW that you want to run.

 

My recommendations for installation include:

  • Install the minimum that you need.  If you don't need multiple versions, install only one.  It is sometimes easier to install older versions than the most recent.
  • Download the latest Installer from the NI Download site (even if you already have one -- they keep updating them).
  • Install 32-bit LabVIEW unless you need 64-bit.
  • Install LabVIEW (by itself) first, reboot, install the minimum set of Toolkits and Modules you need, reboot, install Drivers.  If you don't need it, don't install it.

Bob Schor

Message 2 of 5
(969 Views)

Bob

Confirmed, that was what I ended up doing also. Uninstalling everything and starting from scratch. I wonder if the NI LabVIEW software has grown to such a big monster now, that NI has more or less lost control of it. Thats why they would prefer that we all dropped LV and went over to the NXG.

M

0 Kudos
Message 3 of 5
(920 Views)

Please let me introduce my case.

In my case, I tried VeriStand 2018 SP1 on Windows 10 (1703 version), but failed with the error message as following.

  - The 'NI MXS 18.5.0' installation has failed with the following error:

    Error 1722. There is a problem with this Windows Installer package. ...

 

This problem is because of that Windows service 'Windows Installer' is not started, so you should start this service.

  - Windows Start button - Type 'services.msc' and Enter - Find 'Windows Installer' and Start.

 

This might not fit your case, but I hope this will be helpful to someone.

 

0 Kudos
Message 4 of 5
(899 Views)

@MartinP wrote:

I wonder if the NI LabVIEW software has grown to such a big monster now, that NI has more or less lost control of it.


I don't think that's quite the problem they are having -- rather I think that they are trying to introduce one new item, the NI Package Manager, which also functions as the default Installer for LabVIEW "Packages", including for LabVIEW itself.  It's my belief (but without any convincing data, which means I'm probably wrong) that something went a little bit awry in the design of NIPM and/or how the Installer part of it interacts with the "packages" that make up the various Modules, Toolkits, Drivers, add-ons, etc.  One mark of NIPM's "immaturity" is the presence of the Error Message suggesting that there is something wrong with the internet connection (after downloading GBs of packages -- no, it is unlikely to be the Network Connection ...).

 

There are some "nice ideas" in NXG, but it definitely is not Ready for Prime Time.  There is a lot that still seems to be "missing" from NXG, and speaking for myself and a number of pretty seasoned LabVIEW Developers who have tried to "self-learn" NXG, the lack of good tutorial material, particularly a "Getting Started with LabVIEW NXG for Experienced LabVIEW CLDs and CLAs" would be helpful.

 

Bob Schor

0 Kudos
Message 5 of 5
(886 Views)