LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI MAX - "NI Sercive Locator not running" -- NI Update service - "no communication possible"

Good day,

 

I tried to install the NI Device USB-6525 when I noticed some problems with my Labview installation.

 

The first is that when I open NI MAX the program shows the message "NI Service Locator not running"

max_1.PNG

 

And the NI USB-6525 device is shown as available but I can't use or configure it.

 

max_2.PNG

 

Then I tried to solve this problem via updating Labview but the NI-Update Service says that there is a communication problem.

 

update_2.PNG

 

I also tried:

- restart the PC

- restarting NI Service Locator, NI System Web Server

- reinstall device driver

- testing another USB port

- repairing Labview, MAX, Update Service

 

The NI USB-6525 device functions properly on another PC with Labview 2014, MAX v14.0

 

System:

Win 7 32-bit

Labview 2014

MAX v14.5

0 Kudos
Message 1 of 10
(1,580 Views)

 

If I understand your problem, perhaps this would solve it. A shot in the dark.

 

 

 

LabVIEW is always installed first then the driver set, which has the MAX software in it.

 

 

IF LabVIEW is installed but not the latest driver set immediately afterwards then things similar to your problem could happeneven if the drivers were already on the machine.

 

0 Kudos
Message 2 of 10
(1,563 Views)

So, you mean to remove MAX and install it again or remove Labview completely and install everything again?

0 Kudos
Message 3 of 10
(1,558 Views)

For reasons that I fail to understand, LabVIEW has become "fragile", lately, with installations to add features (or update Versions) sometimes causing essential NI Services (the NI Service Locator is a good example) to stop running.  I usually encounter this 2-3 times a year, sometimes more often.

 

Something that often seems to work is to go into Windows, Control Panel, Programs, find the NI entry, and choose "Repair".  Be sure to have all of your installation disks on hand, as it will ask for them.  You also need to know on which disk what Module or Toolkit is located, which can be something of a pain now that NI does not seem to include a "Table of Contents" page in the Kit.  However, if you open the DVD and look in the Distributions folder, you can often "guess" by looking at the Folder names.  For example, LV_MASM is the Multi-Core Analysis and Sparse Matrix Toolkit (boy, I really picked an "intuitive" one, didn't I).  And in case you can't figure it out, try the DVDs one at a time -- if you have the wrong one, NI will tell you ...

 

If you have multiple "editions" of LabVIEW (e.g. 2010, 2011, 2012) installed, you will probably need their DVDs as well.

 

Before I learned this trick, the only thing that (reliably) worked was a complete Uninstall/Reinstall cycle.  However, since it was an installation that actually caused the problem, one other thing that I did was to do a Reboot between every Toolkit/Module install.  At least the Repair pathway is faster and easier ...

 

Bob Schor

0 Kudos
Message 4 of 10
(1,549 Views)

I already tried repairing Labview and MAX but that doesn't solve the problem.

 

I also have only installed Labview 2014, no older versions.

0 Kudos
Message 5 of 10
(1,540 Views)

 

I would not do that just yet since you stated that you installed driver for your USB card (I presume afterwards) and then

this problem appears. Supposedly installing a driver has no effect whatsoever on the labVIEW installation or version.

 

ALso is your machine using security software?  NI Update service triggered IT to come and see me about my machine once.

I turned it off and update manually.

 

Perhaps someone alse has better advice than mine,

(I currently do not use or have version 2014 anyway.) although in theory if you did do a clean wipe of everything and then installed

everything it should work.

 

But what Bob Schor has stated (LabVIEW seems to be getting more fragile lately) seems to be a fair opinion based on experience watching the forum questions that come up every now and then.

 

Someone else here will know more..

 

 

 

0 Kudos
Message 6 of 10
(1,534 Views)

Here are some of my thought/suggestions:

 

  1. Try running MAX as an administrator (right-click > Run as administrator). This sometimes fixes issues with configuration.
  2. The NI USB-6525 requires the NI-DAQmx driver. Can you verify that the driver is installed? You should see it listed under the Software tab in MAX or in Window's Programs and Features under National Instruments Software. You can also try repairing the NI-DAQmx driver. Order does matter, so you'll want to do driver installation/repairs after LabVIEW is installed/repaired.
  3. You also need NI Configuration Manager and NI Device Loader services to be running. Sometimes these services turns off after a new installation, so make sure to reboot your computer after installations/repairs for these services to work properly. If these services are not starting properly upon reboot, please see more informationn this KnowledgeBase: Why Are NI Device Loader (nidevldu) and NI Configuration Manager Services Not Startin...
  4. Do you get any errors when you try to restart NI Service Locator or NI System Web Server?
  5. According to this KnowledgeBase article: Error: NI Service Locator is Not Running, in addition to restarting the services you may also need to make sure your firewall allows NI Service Locator and NI System Web Server. The fix depends on which firewall you use. For example, Windows firewall has these steps.

Sorry to hear about the trouble you're experiencing. Hope this helps!

Taylor B.
National Instruments
0 Kudos
Message 7 of 10
(1,515 Views)

@leswile wrote:

I already tried repairing Labview and MAX but that doesn't solve the problem.

 

I also have only installed Labview 2014, no older versions.


I don't know what you mean by "repair LabVIEW and MAX".  Here's explicitly what I mean --

  1. Open Control Panel, choose Programs and Features (Windows 7).
  2. Find National Instruments Software.  Right click, choose "Uninstall/Change".
  3. Select all of the software on the left, and click "Repair".
  4. Shuffle disks as required.
  5. Reboot.

That is the sequence of steps that (usually) fixed bad installations or "dying services" for me.

 

BS

0 Kudos
Message 8 of 10
(1,504 Views)

Sorry, if I have LabVIEW 2015 what should I do?,because i tried to fix with your tips, but it didn´t fix the problem

0 Kudos
Message 9 of 10
(1,142 Views)

@PipoPinto wrote:

Sorry, if I have LabVIEW 2015 what should I do?,because i tried to fix with your tips, but it didn´t fix the problem

You are replying to a question asked (and probably answered) a year and a half ago.  If you have a new question, post a New Message (specifically, do not Reply to this message).

 

In your New Message, give it a meaningful title.  Then describe the problem.  Tell us as much as you can about your installation (PC/Mac, which OS, which version of LabVIEW and how many bits, what hardware, has it worked previously or is this a new installation, etc.).  We need to know your situation, which (by your own admission) is not the same as that of the Original Poster.

 

Bob Schor

0 Kudos
Message 10 of 10
(1,126 Views)