LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

NI Hardware cDAQ not found in virtual machine

Solved!
Go to solution

I am using a virtual machine, hosted by VirtualBox. I can pass through any number of USB devices, including my cDAQ-9174. However, despite it appearing in Windows Device Manager, MAX and NI Device Monitor refuse to see it. Anyone know how to solve this?

noNIdevicefound.jpgAfter a few minutes, this device oddly appeared in MAX. It's still not right because I cannot interact with it, and LabVIEW cannot see it:

oddMAXdevice.jpg

Thoric (CLA, CLED, CTD and LabVIEW Champion)


0 Kudos
Message 1 of 6
(661 Views)

My situation didn't involve a VM, but when I had a similar problem restarting/power cycling my cRIO fixed the problem. Probably you already tried that, but if not might be worth a shot.

0 Kudos
Message 2 of 6
(628 Views)

Thank you for the reply cbutcher. Unfortunately I did already try repowering my cDAQ.

I think my cause is futile however because NI admit to not supporting USB devices through VMs.

I'm still hoping however that someone has managed to achieve this, even if it is an unsupported technique.

Thoric (CLA, CLED, CTD and LabVIEW Champion)


0 Kudos
Message 3 of 6
(616 Views)

I know that this is a ridiculous, circuitous and somewhat unhelpful possible solution given you're probably developing on a VM and won't deploy to one (at least, I'd guess not) but you could consider a USB to Ethernet conversion port?

 

I don't know if this would help (especially compared with perhaps trying a different VM provider) but they're not particularly expensive and if it's only the direct USB connection that's frustrating MAX it might (?) be worth trying...

0 Kudos
Message 4 of 6
(601 Views)
Solution
Accepted by topic author Thoric
07-03-2018 03:11 PM

Are you sure you have DAQmx (and a version that supports 9174) installed on this VM? Also check your VM configuration to make sure it is passed-through, and check if host doesn't block the device somehow. (I know, I know, basics.. Smiley Wink )

 

(I've used USB-6008 on VM in the past, but it was OpenSuse guest system. I could use it without problems, so it is possible to use DAQ in VM, at least in my scenario).

Message 5 of 6
(577 Views)

Well, I'll be blown. So whilst this was a problem I'd created a simulated device for the cDAQ 9174 and the three modules that are attached. These simulated devices all work fine, and are support in DAQmx 17.0 (which is the version I have installed).

To try out your theory, I upgraded to DAQmx 18.0 and suddenly Win7 began installing drivers for the cDAQ when I plugged it in. It's now present and working!

So it appears I could simulate the devices in an older version of DAQmx than is required to support the actual hardware? I can't say I understand, but I thank you for making the suggestion, and I thank my patience also for bothering to try it out.

Thoric (CLA, CLED, CTD and LabVIEW Champion)


Message 6 of 6
(562 Views)