Showing results for 
Search instead for 
Did you mean: 

NI Device Loader service not starting, even after NI DAQmx 9.6

Have tried things suggested in the forums and by tech service.  Latest attempt was installing NI DAQmx 9.6  NI Device Loader (nidevldu) is still not starting at bootup on WinXP.

Wrote a little Labview program that calls the Windows SC utility to start NI services.  It only works if the user is Administrator.  Our friendly IT department is locking down computers so that most of my users can not be admin on the machines they are using.


Need to find a fix that is independent of fiddling around in Windows.


After NIDAQmx 9.6, NI mdns Responder does not show as a dependency of NI Device Loader.  Supposedly, that was to be part of a fix, but it doesn't seem to be sufficient.  NI Device Loader needs to start, and it isn't.

0 Kudos
Message 1 of 2

I might have been hasty.  After another reboot, NI Device Loader seems to be starting, even after several reboots.  Only tested on one machine so far, but this is more progress than I've had to date.  Looks like NI DAQmx 9.6 might actually fix the problem.

0 Kudos
Message 2 of 2