LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI-DAQmx Base 2.0 and Win Mobile 5

Solved!
Go to solution

Hi,

 

Can anybody tell me if NI-DAQmx Base 2.0 is compatable with Win Mobile 5 devices?

 

I'm trying to capture analogue voltages and my app builds fine and loads to the PDA, but the PDA is not seeing the PCMCIA DAQ card (6062E) that I'm using.

 

I have run the "Base" installer which has copied the Base driver file/s to the PDA (and I have the Base task setup OK in the VI), but the PDA comes up with an "Unrecognized Card" error. I have removed the Base driver/s from the PDA and reinstalled them but with no luck.

 

 

Is this just because Base 2.0 is not compatable with Win Mobile 5?

 

Is there any way I can get Base 2.1 to work with LV-Pro-8 and PDA-8 or is there some other way I can get the drivers onto the PDA that will handle the 6062 card under Win Mobile 5.

 

Any help would be greatly appreciated,

 

Thanks,

 

Paul.

0 Kudos
Message 1 of 10
(1,859 Views)

Hi Paul,

 

Good afternoon and I hope your well today.

 

Thanks for your post.

 

Firstly, have you seen this knowledgebase article?

 

LabVIEW Mobile Module Software Requirements and Supported Devices

http://digital.ni.com/public.nsf/websearch/7D65D66EB07111F186256EBD005A5499?OpenDocument

 

It explains that Windows Mobile 5 was first supported by LabVIEW 8.0.1 (with LabVIEW Mobile - (LabVIEW PDA)) 8.0.

 

The readme for DAQmx Base 2.0.1 states,

Devices Supported by NI-DAQmx Base 2.0.1 for Windows include the 6062E & it supports LabVIEW 8.0 or 8.0.1 and LabVIEW PDA 8.0.1f1.

 

Have you installed the patches for LabVIEW 8? 

 

Kind Regards
James Hillman
Applications Engineer 2008 to 2009 National Instruments UK & Ireland
Loughborough University UK - 2006 to 2011
Remember Kudos those who help! 😉
0 Kudos
Message 2 of 10
(1,855 Views)

Hi James.

 

Thanks for your reply.

 

I haven't applied any patches so far. Would they be likely to add Win Mobile 5 drivers?

 

Also, I've done a quick search, but is there a Patch index somewhere?

 

Thanks again,

 

Paul. 

0 Kudos
Message 3 of 10
(1,847 Views)

Hi Paul,


Yes. LabVIEW 8.0.1 and PDA 8.0.1 did add support for Windows Mobile 5, as the article linked shows.

 

If you go to ni.com/downloads and search labview pda you will find the patch. If you look at the readme file you will see it states, added support for windows mobile 5.

 

Note: Remember to update LabVIEW and LabVIEW PDA! 

 

This maintence release is free for users who are currently using LabVIEW 8.0. You can't install this on a machine without having LabVIEW 8.0 installed. This product does not require re-activation of LabVIEW. 

 

Hope this helps, 

Message Edited by Hillman on 05-27-2009 02:28 PM
Kind Regards
James Hillman
Applications Engineer 2008 to 2009 National Instruments UK & Ireland
Loughborough University UK - 2006 to 2011
Remember Kudos those who help! 😉
0 Kudos
Message 4 of 10
(1,840 Views)

Hi Paul,


One final note, when upgrading your software please make sure that LabVIEW is closed. Update firstly LabVIEW.. reboot. And then update PDA (Etc) and then reboot. Then start investigating the PDA. 

Kind Regards
James Hillman
Applications Engineer 2008 to 2009 National Instruments UK & Ireland
Loughborough University UK - 2006 to 2011
Remember Kudos those who help! 😉
0 Kudos
Message 5 of 10
(1,833 Views)

Hi Paul,

 

One final final point, could you please update on your progress and if this resolves the troubles you were having?

Kind Regards
James Hillman
Applications Engineer 2008 to 2009 National Instruments UK & Ireland
Loughborough University UK - 2006 to 2011
Remember Kudos those who help! 😉
0 Kudos
Message 6 of 10
(1,814 Views)

Hi James.

 

Thanks for your help with this.

 

We ended up moving to LV8.6, Mobile 8.6 and DAQmx Base 3.2 but unfortunately we still have the same problem.

 

I'm meeting with the PDA people tomorrow and will try a Win Mobile 6 device.

 

Fingers crossed.

 

Thanks again,

 

Paul.

0 Kudos
Message 7 of 10
(1,797 Views)

Hi Paul,

 

Good afternoon and I hope your well. 

 

One thing to bear-in-mind is that DAQmx Base doesn't offically support Windows Moble 6 devices - even though they have been seen to work. This is not to get confused with LabVIEW 8.6 which does support Windows Mobile 6. i.e. just not DAQ applications/DAQ hardware. 

 

I am another customer, here at NI UK Support and I have another customer with the an issue with WM6 and DAQ CF, I'd like to work more with you on this.. could you please provide more details on how it goes tomorrow and the tests you do. 

 

For reference please look at these links: 

http://zone.ni.com/devzone/cda/tut/p/id/7705#toc0

http://digital.ni.com/public.nsf/allkb/F6576C46AD7B42768625758200510715?OpenDocument

 

Thanks

Kind Regards
James Hillman
Applications Engineer 2008 to 2009 National Instruments UK & Ireland
Loughborough University UK - 2006 to 2011
Remember Kudos those who help! 😉
0 Kudos
Message 8 of 10
(1,790 Views)
Solution
Accepted by AU777

Hi James.

 

Sorry for my delayed reply.

 

The problems were a combination of LV8.0, Base 2.0 and a hardware fault.

 

In the end I went with LV8.6, Base 3.2 and Win mobile 5 with either a 6062E or 6024E PCMCIA card.

 

The Base hardware config utility is a little different and took a little bit of fiddling to get going. I also found some documentation that lead me up the wrong path Re. saving base tasks to the project and/or device but now I understand it everything is good.

 

I do not know if your customer is still having problems but I am more than happy to help if I can.

 

Thanks for your help as well.

 

Best regards,

 

Paul. 

Message Edited by AU777 on 06-18-2009 08:24 PM
0 Kudos
Message 9 of 10
(1,691 Views)

James.

 

The first link you show above is the one that threw me.

 

In the section "Create a Mobile VI Using a Static Task" (points 10, 11 & 12) it says to save the Base task as BASETasks.cfg to the Sync folder which ultimately gets copied to the PDA.

 

"I" took this to mean the PDA would use the CFG file for its tasks and spent some time fiddling with the CFG file without actually rebuilding the EXE.

 

Just in case others read this the same way, the last settings you save into the Base config utility are the ones that get built into the EXE. So I was playing with the CFG file looking for I/O changes and the EXE was only using what had been saved and built into it earlier. (And this must happen in the project. ie. you must save & exit out of the base config utility with the project open else the updates you just made don't get built.)

 

Smiley Happy

 

Paul.

 

 

0 Kudos
Message 10 of 10
(1,688 Views)