LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

NI-845x Driver 19.0 - download link is missing

Hi,

 

I need to use a special version of NI-845x Driver - 19.0  or 19.5 (if it was released).

 

The version 19.0 is not available here - https://www.ni.com/en-us/support/downloads/drivers/download.ni-845x-driver-software.html#346270

 

NikitaProrekhin_0-1606473765638.png

 

 

According to this document however - https://www.ni.com/en-us/support/documentation/compatibility/16/ni-845x-driver-and-labview-compatibi... - the version 19.0 exists and should be available.

 

Do you guys know, where can I get this specific version? Thank you!

Nikita Prorekhin
CLA
0 Kudos
Message 1 of 5
(202 Views)

I also could not find a LabVIEW 2019 driver for the NI 845x USB SPI master.  I downloaded the 845x-1800 version, installed it, and it works fine with my LabVIEW 2019 code.  In recent (2-4) years, NI has been releasing Drivers that can work not only with current and older versions of LabVIEW, but with yet-to-be-released versions (not sure how they work this trick, but it seems to work).

 

Bob Schor

Message 2 of 5
(171 Views)

Yep, the 18.0 release can be used with LabVIEW 2019 with some tricks and manual copy-paste magic.

 

It would be nice if NI would comment on this and fix the error on the web-site.

 

Nikita Prorekhin
CLA
0 Kudos
Message 3 of 5
(145 Views)

As long as you are not using LabVIEW 2016, I recommend just using the 20.0 version.  According the the readme, the only thing that changed was LabVIEW (added 2020 support and removed 2016 support) and CVI (removed 2013 support).


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 4 of 5
(139 Views)

We have a special case where we need to support both LabVIEW 2016 and LabVIEW 2019 on the same machine, so the 19.0 version is exactly what I want.

 

I hope NI has this version on their servers but just forgot to publish it.

 
 

 

 

Nikita Prorekhin
CLA
0 Kudos
Message 5 of 5
(120 Views)