Showing results for 
Search instead for 
Did you mean: 

.NET Callback Event VI keeps the Callback VI reserved even GC.Collect() is used in Labview 2018

Go to solution

Hi all,
since years I use .net callbacks in Labview and till now I use the GC.Collect function to free the Callback VIs.


Now I use Labview 2018 and it seems that this doesn't work anymore ...


Does anyone else have this experience?

It also seems that in LV2018 the .net is changed more, because if use the Maun->View-> net assemblies in memory, I get a corrupted labview error ...



0 Kudos
Message 1 of 12
0 Kudos
Message 2 of 12

Hi, thanks for your reply . 

The problem is that the workaround GC. Collect doesn't seem to work anymore in Labview 2018.

Best regards 


0 Kudos
Message 3 of 12



You're not alone.  You're seeing a couple of issues we've noticed specifically in LabVIEW 2018.


The error message you're seeing is being tracked by CAR 707767.

The GC.Collect() method not releasing the reference is being tracked by CAR 712176.


Our dev team is aware of both and working to resolve those as soon as we're able.  In the short term, we don't have a workaround for the error in 2018.  But, if you have an older version of LabVIEW installed, you can setup your .NET functionality and then open in 2018 without any known problems.  For the GC.Collect(), the only suggestion I have is to consider placing the callback into a library.  Libraries are easier to unload without closing out of LabVIEW.  But, that's not really that much more friendly than your current state.


Are these actively holding you back?  Or, are you wanting to report them as issues to make sure there's nothing quirky with your installation?

0 Kudos
Message 4 of 12

Hi, thanks for the info.

So I'll hope for a solution in the future ..

Meanwhile I develope in LV2017 and copy it to 2018 folder ... nice for Subversion 🙂


0 Kudos
Message 5 of 12

Hi, it seems that this issue is fixed now in Labview 2018 f2 patch, BUT:

I can't download it anywhere ...

This: says "This patch can be found by the NI Service Update tool", but it can't.

There is also a download link on this page, but it doesn't exist...



0 Kudos
Message 6 of 12
Accepted by topic author Johann78

Sorry about the early documentation.   You're right, though.  This problem is fixed in the 2018 f2 patch and it's now released.  All of the links on the patch details page you listed should now be live and the patch can be downloaded.


Message 7 of 12

Hi, thanks for the info, but when I try the f2 patch windows links on the bottom side of

I still get the page error:

And my NI Update Service doesn't find it ...


0 Kudos
Message 8 of 12

Hi, now it's working!

My problem was that I use Firefox ....

In Chrome it works now.



0 Kudos
Message 9 of 12

For anyone that may be watching this thread, this fix is also included in LabVIEW 2018 SP1.  If you'd prefer upgrade to SP1 rather than patch, this is available to download at now.

0 Kudos
Message 10 of 12