LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

MyRio 1900 - Error list

Solved!
Go to solution

Hey,

 

its been a while. I wasnt able to enter the University before.

I took the Laptop from the University (not my own, where I tried to install some Software before. Will be probably woking with the one from University).

 

Here are the pictures:

 

Software.png

 

The Rio is shown under Devices and Interfaces, however under Remote Systems it is not shown after searching. Tried to look for some solutions but it did not work right now. There were also different kind of solutions (Tried to reset the configuration data under Tools by now).

The Rio is connected via USB Device Cable.

 

RemoteSystem.png

 

Greetings

0 Kudos
Message 11 of 19
(309 Views)
Solution
Accepted by topic author Suryoyono

You may have a difficult time setting up your myRIO as you are using outdated versions of LabVIEW (2014, more than 5 years out-of-date, which NI now considers outside of "normal support").

 

The myRIO is designed as a "Real-Time Target", meaning that it runs its own Operating System (I'm not sure what the OS was in 2014, but now it is NI-Linux Real-Time).  In order to use it with LabVIEW, you must configure your LabVIEW PC to include the LabVIEW Real-Time Module, and the myRIO Toolkit.  Once you do that, MAX should be able to "find" your myRIO through the USB connection, and will also be able to update the (now-obsolete) software in the myRIO.

 

In the LabVIEW Real-Time environment, there are three pieces of software that need to be kept "synchronized" with respect to Version:  LabVIEW itself (running on one or more PC, including the LabVIEW Real-Time Module and the corresponding Drivers for the RIO hardware, mainly Version 19.5 or 19.0 on my PC), the Firmware and OS running on the myRIO (I'm currently running Firmware Version 7.0.0f0 and NI Linux Real-Time ARMv7-A, with a string of other letters following), and the Device Drivers that MAX installs on the myRIO (most of them on my system are Version 19.0).

 

If you have (all of) the installation media for your version of LabVIEW (2014) and the installation media that came with your myRIO six years ago, you could try to

  • Upgrade your LabVIEW Installation to include the Real-Time Module
  • Make sure you have the required LabVIEW Drivers for the myRIO (which I presume you'd find on the myRIO CD)
  • Run MAX, use it to verify you can now "see" your myRIO, and update the myRIO's firmware and software.

If this succeeds, you should have a working myRIO system.  If it doesn't, you can still "recover", but it would probably involve a major upgrade, starting with your PC -- if you are running LabVIEW 2014, it is unlikely that you are running Windows 10.  You would want to configure the following platform for using your myRIO in the year 2020:

  • A PC running Windows 10, a 64-bit operating system.
  • An installation of LabVIEW 2019 (or LabVIEW 2020, though I have not checked if it still supports myRIO -- my recommendation would be LabVIEW 2019, 32-bit, which I know works).
  • The myRIO Toolkit 2019 (I don't think there's a 2020 version yet available).

With these components installed on your (new) PC, you should be able to use MAX to find the connected myRIO, to update its firmware, and to install the software modules that the myRIO needs.

 

Bob Schor

Message 12 of 19
(302 Views)

Hey Bob,

 

Thank you very much for that great answer. I am sorry that my answers always take some time.

I will follow your steps (I guess i will try it with the 2019er as you recommend) and hope for the best. It may take some time until I am able to try it all. Thanks for your patience.  

 

Have a blessed day

0 Kudos
Message 13 of 19
(287 Views)

Hello Bob,

 

its me again.

With your detailed response it was exceptional easy to install everything

I followed your 2019er advice

The pictures of the old software (if youre interested haha)

 

MyRIO.PNG

MyRIOII.PNG

I updated it to the Firmware Version 7 and installed the 2019er Software on it.

The originally error is therefore fixed. Thank you very much

 

__

 

I still have another question if you want to answer

There are some other problems occuring.

 

I tried to find the vis of the MyRio on the palette but didnt find them. I can drag them in from the folder where they are installed however if i try to add them to the block diagramm or find on the palette (its via the help window) I get the following error:

 

HelpONF.png

 

and when trying to run the Code I got from the other student, the following error list still occures.

 

ErrorList.PNG

I wanted to know whether the problem lies still with some software issuses or now difficulties with the folders and target datas. He is showing this while clicking on "Show Error" and is marking the Smart Open Vi

 

ShowError.PNG

The Current default setting is: LabVIEW for myRIO

Maybe I missed something in the installation progress

 

Thanks again for your kind and patient help Bob.

0 Kudos
Message 14 of 19
(266 Views)

When you turn on your computer and plug in the myRIO, you should get a pop-up asking what you want to do with the myRIO.  Have you tried any of their "Getting Started with myRIO" things?  [I haven't plugged a new one in for a few weeks, so I forget the actual question it asks ...].

 

When you open LabVIEW, does it come up as "LabVIEW 2019 myRIO Toolkit"?  If not, go to Tools, Choose Environment, and select myRIO Toolkit.

 

Open LabVIEW.  Create New Project.  Under "Sample Projects", you should see "myRIO".  Select a Sample Project and follow the directions.  If you can't get started, take some screen shots, attach some code, and reply here ...

 

Bob Schor

Message 15 of 19
(261 Views)

A followup to my previous post.  Once again, you are asking for help solving a problem that comes when you attempt to open (or run) some LabVIEW code.  You know I'm willing to help, you know that I have a myRIO connected to this PC, yet you refuse to attach your code, but you still want me to help you with it!

 

I promise to give you no more help until you "help me to help you" by attaching the LabVIEW code that you are trying to run and that is giving you errors.  Feel free to explain what "goes wrong", so when I load it, I can say "Oops, the same thing happened to me, let me see if I can fix it", or "Hmm, on my system, it just opened and ran perfectly", or "Do you have Such-and-So installed?".

 

Bob Schor

 

P.S. -- I apologize for that last paragraph, but it is so frustrating to think I might be able to help, but my lack of Mind-Reading Skills prevents me from "seeing the code you haven't attached" ...

Message 16 of 19
(252 Views)

Hello again,

 

sorry if I frustrated you in this process of problem solving. I guess I overread the part with attaching the code but yeah it should have been obvious to share it. So in this case sorry Bob.

Your paragraph is fine. I get your point and Im still thankful for your help and especially for your patience. I am the one asking for help and therefore I have to provide you with every needed information.

The Code I got for the project should be attached now.

 

To answer your first post I need a week to answer. It was my bad that I didnt check my mails before I left University. But I´ll do it as soon as possible.

If I open LabVIEW it at least come up as LabVIEW2019 myRio Toolkit. And under Creating a new Project there is myRio under Sample Projects. I´ll try the Sample Projects when the Rio is connected.

 

I hope you have at least a great day

 

PS: I think your Mind-Reading Skills arent that bad. I like you Bob, youre a good man.

0 Kudos
Message 17 of 19
(229 Views)

Hello, Samuel.

 

I just re-read your initial Post, and have been thinking about the issues you've been raising.  I have a suggestion, based on what what you've said, that may help you and get this Project going.

 

I'll start by noting that this is an "old" Project that someone else developed, which might (or might not!) have run, but certainly didn't run on the hardware and software you had available.  You were able to update the LabVIEW software, but there is still difficulty in getting the old code to work.

 

And now I see what I'm guessing is the Old Code.  It is not so horrible, but is definitely "old", uses poor LabVIEW Style, and shows poor understanding of how to program a myRIO.  So let's tackle this issue.

 

Warning -- the first thing I'm going to say is I recommend you put this Project away (don't look at it), spend a little bit of time trying to learn a bit more about LabVIEW, follow some specific "learning objectives" I'm going to give you, learn a little bit about LabVIEW "style", learn how to program a myRIO, and then try to develop code to do "what you want to do", but without looking at the (poor) code you just posted.

 

Have you taken the LabVIEW tutorials that are offered on the front page of this Forum?  I know that NI was making some of the "Learn LabVIEW" tools available free-of-charge during the CoVID crisis, and hope (as part of their "rebranding" efforts) they might still be available.  I strongly suggest you try to complete Core 1 and Core 2.

 

But the first thing (and one of the first things I learned that started me on the road to becoming a better LabVIEW developer) is to improve your LabVIEW "Style".  There's an excellent book, "The LabVIEW Style Book", by Peter Blume, that is mostly about Style, but so much more!  Here are a few tips from it I urge you to implement:

  • Try to keep your VIs "neat and compact".  Wires should (as much as possible) run straight, left to right, with few bends.
  • Use the Error Line as much as possible.
  • Avoid large amount of "white space" -- keep your Block Diagram compact.
  • Sub-VIs are your friend.
  • Turn off "Place front panel terminals as icons" on the Block Diagram (helps implement two of the above points).  To do this, go to Tools, Options, Block Diagram, uncheck the first box.

Now go through the Tutorials.  

 

I notice you are building arrays using shift registers, with a Boolean controlling whether or not to add a value to the Array.  Learn about the Conditional option on the Indexing (output) Tunnel, which eliminates the need for the Shift Register.  This wonderful improvement to LabVIEW was introduced about 8 years ago!

 

Once you've gained some more experience with LabVIEW code, learn about coding with myRIO.  When you plug the myRIO into your PC, you are offered some "Learn myRIO" options (I don't remember now what they are -- I don't have a "plugged in" myRIO, so I don't see that pop-up any more).  You should also do all of the Sample Projects that LabVIEW offers you (open LabVIEW, New Project, myRIO).  Programming the myRIO is "a little different" than programming LabVIEW on the PC -- I only started serious work with the myRIO a few months ago, and it is difficult for me to "unlearn" my good "PC" skills for the differences required for working with the myRIO (for example, that Sequence Structures "are your Friends").

 

Bob Schor

Message 18 of 19
(207 Views)

Hey Bob,

 

Thanks for your answer and advices,

 

I got some starter books from the library and searched for some LabVIEW tutorials to get to used to the program.

It seems that the Core 1 and 2 courses are not free anymore but I´ll try to learn it without them for now.

 

Before beginning the "Getting started" stuff from the MyRio I follow your counsel and start with LabVIEW itself. That should take some time. I went through the Getting started of the Rio very briefly, just to get a look.

 

Talked with my student thesis caretaker and he supported your advice not to use the old code and start with a blank one.

I guess its now my turn to study LabVIEW haha.

 

I wanted to thank you again for your great help and huge patience with me. I know the Kudos arent enough but hopefully they show at least a small amount of my gratitude.  

 

Samuel

0 Kudos
Message 19 of 19
(184 Views)