LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

My device (niScope-5102) is detected in MAX, but not in Labview

Solved!
Go to solution
Highlighted

 

Hi,

 

My niScope-5102 was working fine even though it is quite old. Today, I formatted my PC and reinstall windows 10 (It was windows XP) and Labview 2017. Suddenly, my 5102 is not detected in Labview. However, it is detected in others such as MAX and device manager. Is there any solution?!

Thanks

image.pngNI-SCOPE Express

 

image.pngMAX

 

image.pngDevice manager

 

image.pngSoft panel

 

 

0 Kudos
Message 1 of 5
(831 Views)

After you finished the LabVIEW installation, did you also install the NI SCOPE driver? This driver is needed to see and interface with the scope card correctly.

0 Kudos
Message 2 of 5
(771 Views)

Yes, I installed SCOPE 17.1.1 which should be no problem. Also, I installed Windows 10 32bit rather than 64bit.

image.png

0 Kudos
Message 3 of 5
(765 Views)
Solution
Accepted by topic author Enhorse

There are a number of significant changes that NI made in going from LabVIEW 2016 to LabVIEW 2017.  While the NI-Scope 17.1 drivers say they are compatible with your niScope-5102, it is possible that something in the LabVIEW 2017 code got a bit mixed up (I, for one, have had LabVIEW come crashing down when I installed 2017 on three different machines, with two of them requiring a C: drive reformat and reinstallation of Windows to repair -- I'm hoping to avoid it on the third machine, will know next week).

 

If you have access to LabVIEW 2016, I would suggest that it may be more "stable".  Unfortunately, you'll need to uninstall all existing NI Software first, and this can be tricky with LabVIEW 2017 (see previous paragraph), so I'd call NI Support first (unless you want to "start over" again ...).

 

Don't worry about running 32-bit LabVIEW -- the more stable (and probably much more common) installation is 32-bit LabVIEW on 64-bit Windows (all of our systems are configured this way).

 

Bob Schor

0 Kudos
Message 4 of 5
(747 Views)

Thanks!!

I solved the problem by installing Labview 2016 with niScope 16.

I think my old device is not working well in the latest version of Labview even though they said that it is compatible..

0 Kudos
Message 5 of 5
(739 Views)