LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Multiple polar plots into a 3d plot


Kamilan wrote:

Hello Ben,

 

I know this code is old but I have a question. I am not entirely sure how to correctly set up the colourmap/colour value vi.

 

You see, I have some data that varies from 400 to 2000. I want to set the maximum value of 2000 to dark red for example. However, the activex always seems to autoscale it and maps the maximum value in the data set to dark red. So for example, if the maximum in the data set is 1900, then those plots will be dark red.

 

How do I manually change this, as I have different sets of data, with different  mini and maxi values.

 

Cheers

 

Kamilan

 

 


 

Do you really want to do this manually or automatically adapt to your data set?

 

I posted images above of all of the code including the code that genertes the color ramps and defines the mapping. Since you want to map beyond the range of values in your dataset then you can include your desired max-mins in the data set so tht they drive the range.

 

Post screen shots of your code if you are still having trouble.

 

Ben

Message 21 of 37
(3,213 Views)

Hello

 

I do wish to manually adapt my data set because...

 

We have this pressure sensative film that turns darker as you apply more pressure. I applied the maxium pressure and scanned a sample into a computer. I then have labview look at the darkest set of pixels.

 

Its not very very scientific, but the darkest pixel equals the maximum pressure the film can handle.

 

Thus if I measure an impact and scan the film in, I only want it to be "dark red" if the maximum pixel is detect.

 

My code takes a scanned jpeg image and inverts the image.

 

Converts the pxiels into a distance. (images scanned at 300DPI thus 1 pixel equals 1/300 of an inch)

 

Then displays the images as a 3D surface plot.

 

 

0 Kudos
Message 22 of 37
(3,201 Views)

Hello,

 

I've had a look at your code and I think I've put the the min and max in the right place in your VI.

 

here is my code.

 

It works... sorta, but now only a quater of the image is shown in the 3D plot and the colour map array keeps resetting to the values in your array.....

 

wait... DUUH, make current values default... but still the only a section of the full image is shown.

 

attached is a sample jpeg.

  

 

Any thoughts?

 

Cheers

 

K

 

the image is a hockey ball btw traveling at 30ms-1

0 Kudos
Message 23 of 37
(3,193 Views)

I am trapped at lV 8.5.

 

Please make all settings the default and re-post as LV 8.5.

 

Ben

Message 24 of 37
(3,175 Views)

Hello Ben,

 

Sorry for the late reply.

 

For some reason, my code shows the whole image now.

 

Thank you for your input and examples. Been a huge help to me!

 

0 Kudos
Message 25 of 37
(3,100 Views)

Hello everyone.

 

I am trying to create a VI to display charts of LEDs spatial-intensity.

I reworked the Ben's brilliant VI.

I attach a VI and the data to test.

Please write how can I optimize it. Where have I made mistakes?

Does the cursor can display the description in the spherical coordinates system?

I would like the 3D chart to be built from 3D mesh and it should look like on the drawing below.

 

Thank you for any advice.

Message 26 of 37
(2,330 Views)

Content of attachment:

CWGraph3D spherical coordinate system.vi (main file) - it is my basic study of CWGraph3D and spherical coordinate data (3D polar plots).

CWGraph3D spherical coordinate system test.txt - its test data.

 

Who knows how to change cursor position information to display it as coordinates in spherical system (r[mag], theta[degres], phi[degres]) ??

Message 27 of 37
(2,245 Views)

@uniseb wrote:

...

Who knows how to change cursor position information to display it as coordinates in spherical system (r[mag], theta[degres], phi[degres]) ??


No ideas? Smiley Sad

0 Kudos
Message 28 of 37
(2,186 Views)

i never tried taht but I would first start by setting the coordinate system to cylindrical in the hopes the Cursor will adapt.

 

Ben

0 Kudos
Message 29 of 37
(2,167 Views)

I don't see a property node for it. Can you swap the order that the data is sent into the graph?

0 Kudos
Message 30 of 37
(2,162 Views)