LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

MsiError 1627 during install application built with labview 2009

Solved!
Go to solution

Hello,

I tried to install an application built with labview 2009, i have this fatal error "MsiError 1627: 1: 2727 2: UsFile".

Executable works fine whereas installer doesn't work !

 

UsFile is an Lvclass. i don't understand why i have this message. 

 

thanks a lot.

0 Kudos
Message 1 of 4
(2,263 Views)

Hi,


Try to delete the installer from the project and create it again but do a test with a simple project first and then with your project.

If this not solve the issue, perhaps there is a problem with your MS Windows Installer service, it may be deactivated or corrupted. Here is an installer for 3.1 version of this service, from Microsoft : Windows Installer.

 

Let me know what happens.

 

Regards,

Steve M.
0 Kudos
Message 2 of 4
(2,245 Views)
Solution
Accepted by topic author pca.eurosonic

Hi thanks for answer,

 

I didn't delete the installer. it was not MSI desactivated or corrupted.

 

Problem is in File source : ProgramFilesFolder wasn't as the same as My application. So i refreshed that (the folder UsFile not appeared in ProgramFilesFolde)

Now, it works!

 

thanks a lot Bye

0 Kudos
Message 3 of 4
(2,231 Views)

Hello,

 

I had the same error.

 

I had not set the default installation directory in the destination category in the application builder.

 

-Marius

0 Kudos
Message 4 of 4
(2,000 Views)