LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Moving SubVI's and then relinking, how ?

Hello all.

I want to experiment with a subvi used in a move or less working
program so I started moving the sub vi blocks into another diagram
and then started playing around with the vi. Then I realized I don't
want these changes in the original program so I saved the new diagram
in a new directory and copied the subvi I used over also. When I use
the project menu to look at the hierarchy the full names show that the
vi is coming from the original directory, and the relink option is not
hilighted. Is there an easy way to force the new subvi to link to the
new directory items?

Thank you for your help.

Regards,

Steve Drake
0 Kudos
Message 1 of 3
(1,547 Views)
use save a copy as
e
--
-----------------------------------------------------
Click here for Free Video!!
http://www.gohip.com/freevideo/

Steve Drake wrote in message
news:4oa5bsghpq4qs2j7oimh1kcl2lt8rjoobu@4ax.com...
> Hello all.
>
> I want to experiment with a subvi used in a move or less working
> program so I started moving the sub vi blocks into another diagram
> and then started playing around with the vi. Then I realized I don't
> want these changes in the original program so I saved the new diagram
> in a new directory and copied the subvi I used over also. When I use
> the project menu to look at the hierarchy the full names show that the
> vi is coming from the original directory, and the relink option is not
> hilighted. Is t
here an easy way to force the new subvi to link to the
> new directory items?
>
> Thank you for your help.
>
> Regards,
>
> Steve Drake
0 Kudos
Message 2 of 3
(1,547 Views)
On Tue, 22 Feb 2000 15:50:55 GMT, Steve Drake
wrote:

>Hello all.
>
> I want to experiment with a subvi used in a move or less working
>program so I started moving the sub vi blocks into another diagram
>and then started playing around with the vi. Then I realized I don't
>want these changes in the original program so I saved the new diagram
>in a new directory and copied the subvi I used over also. When I use
>the project menu to look at the hierarchy the full names show that the
>vi is coming from the original directory, and the relink option is not
>hilighted. Is there an easy way to force the new subvi to link to the
>new directory items?
>


Well I think I found an ok way, maybe the only way. I think a nice
way of doing th
is is to use the "REPLACE" option on the subVI's icon
and then use icon "SELECT A CONTROL", now just select the copied
version. Now the links are changed and I can alter the vi without
messing up the running program. This seems to be the best way I can
find so far.

Regards,

Steve Drake
0 Kudos
Message 3 of 3
(1,547 Views)