Showing results for 
Search instead for 
Did you mean: 

Move to Back Keyboard Shortcut Not Working



I've gotten into the habit of making common wires, such as the error cluster, to always be at the back (or under) all other wires on the block diagram. There's a convenient keyboard shortcut to do this for a selected wire: Control+Shift+J. For some reason my setup doesn't take this keyboard shortcut.


Ctrl+J and even Ctrl+Shift+K to move structures to the front work fine. Using the toolbar to do this is OK too, which what I end up doing if I'm not hitting Ctrl+J over and over. I'm using LV 2014 32-bit.


I have a feeling that another Windows app has hold of this keyboard shortcut, but I'm not sure how to figure that out.


Thanks in advance for any hints!

Feel free. Contact me for anything more,

You too can be LabVIEW Awesome!
0 Kudos
Message 1 of 5

I do not know a solution, but it is a bad programming practice if you try to hide wires behind other objects in the block diagram. Why would anyone do that? You are hiding information what the programmer should see. If the reason is a too crowded BD why you do this, you should improve/clean up your design using more subVIs and cluster wires.

0 Kudos
Message 2 of 5



I understood it that they just like the error wire to be under the other wires (and perhaps reference wires or other wires that generally run straight through a diagram). This is a little more OCD than I get with my block diagrams, but even with quick throwaway code I tend to use the arrow keys to get kinks out of my wires 🙂


I do not know why your keyboard shortcut is not working, but I wonder if you might be able to write a script that goes through a VI, or folders of VIs, and moves the error wires to the back, it might be much faster than what you are doing now!

0 Kudos
Message 3 of 5

Hmm, yep I think you are right. Of course some minimal level of overlapping is unavoidable. So in that case the vertical order might help to improve the visibility of important wires...

0 Kudos
Message 4 of 5

Looks like Cisco Jabber was the culprit. Turns out that Ctrl+Shift+J, by default, allows you to copy data from one application to the Jabber app. It also "conveniently" overrides the other's app's same shortcut. A quick look into the documentation and I was able to change a flag to False in Jabber's configuration XML files. Hooray!

Feel free. Contact me for anything more,

You too can be LabVIEW Awesome!
0 Kudos
Message 5 of 5