LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Missing subVI and Could not load front panel.

Solved!
Go to solution

Hello,
I've built an application with the NI Vision Builder application on my computer, and it's working without any errors. But when I copy this application(with all of the VI-s and config files etc) to a coputer, which has installed just the labView RTE and Vision Development Module RTE, I keep getting the errors below on the image. I looked after the missing subVIs, the Common.llb file includes the the IVB Threshold Image.vi and the IVB VAA.llb contains the IVB VAA Templates.vi. With the other error I don't know what should I do, because I couldn't find the lvlib file (could that be the problem?). So why the program can't see the 2 VIs which are in the 2 llb file, and what should I do with the "could not load front panel" error?
I attached the images.

Thanks for your help,
Bence

0 Kudos
Message 1 of 5
(1,714 Views)
Solution
Accepted by topic author Sprake
09-09-2016 05:35 AM
Which version of LabVIEW are you using?

It sounds like you either still have a missing component, or you have installed the wrong version of the component on the target PC.

Generally it is a good idea to make an installer to install the appropriate versions of the components that you need. If you're using LabVIEW 2013 or later, I believe it will automatically select all of the required NI components and include them in the build by default.

If nothing else, look at the list of components it has selected and make sure you have these installed on the target PC.


Certified LabVIEW Architect (CLA), Certified LabVIEW Embedded Systems Developer (CLED) and Certified TestStand Developer (CTD)
MediaMongrels Ltd. - NI Alliance Partner | GDevCon :: 21-22nd August 2019 :: Birmingham, UK
Message 2 of 5
(1,679 Views)

I'm using LabVIEW 2015(32bit) and vision builder 2016(32bit), because the target computer is using 32bit operating system.
That's a good idea, to make an installer, I will give it a try and update if it solves the problem or not. Thanks!

0 Kudos
Message 3 of 5
(1,668 Views)

An IVB subVI is a VI that was created by performing a "Migrate Inspection to LabVIEW..." from Vision Builder for Automated Inspection.

-Which version of Vision Builder you have used in your computer and the LabVIEW version to create the application?

-Which version of LabVIEW RTE and Vision development module RTE you installed?

-If these both versions do not match then generally this missing VI error arises.

 

Coming to your second error: Could not load front panel

-When you build an executable in LabVIEW, Application Builder removes the front panels of all of your program's subVIs. These front panels are generally unnecessary to your program and removing them allows for the creation of a much smaller executable file.
-If you have a program that displays the front panels of subVIs while it is executing, you explicitly need tell Application Builder to include those front panels before creating the executable file.

-Follow the steps in this link and Uncheck Remove front panel.

Thanks
uday
Message 4 of 5
(1,666 Views)

The solution was to create an installer. Thanks!

0 Kudos
Message 5 of 5
(1,652 Views)