Showing results for 
Search instead for 
Did you mean: 

Missing dependencies / can't locate "MB Modbus Command.ctl"

Go to solution

I'm trying to access an old project from LabView 2013 in LabView 2020. I transferred the project's files from a computer to another, however I have missing dependencies when I open the project with the newer version of LabView. I get a message asking to locate "MB Modbus Command.ctl" but the file doesn't exist. 


According to this thread (, I tried using this library (vipm://ni_lib_modbus_library/?repo_url=, but I still can't locate the file. 


I also tried to find "MB Modbus Command.ctl" in the old version files but again it doesn't exist. Any ideas what my problem is ?

0 Kudos
Message 1 of 4
Accepted by topic author FrougeurPro

I downloaded the LLB from and the control was in the LLB.

Matt J | National Instruments | CLA
Message 2 of 4

I'm a bit confused because the library you advised I use was the one I was using from the start. Is the file litteraly named "MB Modbus Command" ? Also, are you using VIPM to install your libraries or is there a way to do it manually ?


I'm sorry if it sounds stupid but i'm new to LabVIEW.

0 Kudos
Message 3 of 4

Nevermind I answered my own question. I was looking for a file that was litteraly named "MB Modbus Command.ctl" when in fact I was supposed to use "NI Modbus" which I guess contains the command.


Thanks for your help.

0 Kudos
Message 4 of 4