LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Missing cRIO 9154 in Add Targets and Devices dialog

Solved!
Go to solution

Hello again all you helpful forum-goers!

 

I have an existing LabVIEW project that includes a real-time Hypervisor PXI target.  One of the devices under that target is a cRIO 9114 chassis.  I now need to add an additional cRIO 9154 chassis so that depending on a conditional disable signal, I can change my code to talk to either the old chassis or the new chassis, thus keeping my code modular across different hardware.

 

However, I am writing my code update on my regular computer that is not hooked up to the target, so when I right-click on the Hypervisor target in my project and select the New -> "Targets and Devices...", I cannot select the "Existing target or device" to be auto-detected.  Instead I click on the "New target or device" in order to just add it anyway, and I expand the CompactRIO folder there, and... no 9154.  I have a bunch of other cRIO devices (see screenshot), including the 9114, but no 9154.

 

I guessed that maybe my LabVIEW installation (2012 SP1) didn't know about that chassis since it was released in the past year, so I tried to install the latest device drivers with the LabVIEW 2013 developer suite discs I just got, but it got hung up while installing (the first time at 0%, the second time at 27% listed as "Validating install", for a long, long time before I gave up and cancelled).  I restarted my computer but no change to the problem.

 

Does anyone have any ideas as to why I can't choose a newer chassis to insert into my project without it being actually attached to my computer?  And was I too quick to give up on the device driver installation, not that I know if that would have solved the problem anyway?  :-P

 

Thanks for your help as always,

 

-Joe

 

Snap 2013-08-15 at 16.24.19.png

0 Kudos
Message 1 of 3
(907 Views)
Solution
Accepted by topic author jmorris

Hello Joe,

 

The NI 9154 is a MXI-Express RIO Chassis therefore it should appear under MXIe-RIO Chassis section.

 

RIO E.PNG

 

As for the install if you are worried that it didn't install properly you can try to run a Repair on the NI-RIO software and look in MAX to see if you have RIO 12.1 or 13.0.

 

Regards,

M. Whitaker
ni.com/support
Message 2 of 3
(887 Views)

You are absolutely right, and I was able to add it with no problems.  While I feel somewhat foolish, that it outweighed by my enjoyment of a simple solution for once.  Smiley Happy

 

Thanks again!

 

-Joe

0 Kudos
Message 3 of 3
(883 Views)