LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Missing Samples in NI 9219

Hi Morya,

 

there is a time column in your Excel file, so what's the problem?

 

Can you attach a TDMS file with some sample data instead?

Best regards,
GerdW
CLAD expired, using 2009SP1 + LV2011SP1 + LV2017 (+LV2018 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink

Message 11 of 22
(146 Views)

The attached file in last reply was the file when I was using Express VI, which I attached very earlier. I m attaching tdms file, which I converted into excel, with few samples. I also attached respective VI. Please check it. I want time column along with all readings as you have seen in attached file in last reply.

0 Kudos
Message 12 of 22
(143 Views)

Hi Morya,

 

I asked for a TDMS files and you uploaded a converted XLSX file.

Please attach a sample TDMS file…

 

That being said:

In the first tab of the XLSX you find the timing information as wf_increment and wf_start_time. From these values you can create your own time column.

Please keep in mind: the file gets converted from TDMS to XLSX using the TDMS plugin supplied by NI. They provide this plugin "as is" with no way to customize its output. When you need a differently formatted output file you need to convert on your own. (Did I mention that before?)

Best regards,
GerdW
CLAD expired, using 2009SP1 + LV2011SP1 + LV2017 (+LV2018 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink

Message 13 of 22
(138 Views)

I attached TDMS file with reduced no.s of samples and sample rate. Actually I have to work on 100k samples and 100k sample rate. I also want to get resistance directly from LabVIEW from Vout and Vsupply readings using formula. Please check that file and tell me how to get time column along with all readings.

0 Kudos
Message 14 of 22
(131 Views)

Hi Morya,

 

I use TDMS really very seldom, but with a few clicks I could read a signal and generate a timestamp array:

check.png

The waveform graph shows the signal, the timestamp array contains a timestamp for each sample in the waveform.

Now your task is to save both timestamps and waveform into one file…

 

Repeating again: when you need a specific data format in your files you need to implement a routine to save exactly this data format!

Best regards,
GerdW
CLAD expired, using 2009SP1 + LV2011SP1 + LV2017 (+LV2018 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink

Message 15 of 22
(125 Views)

Thank you sir.

I use TDMS really very seldom, but with a few clicks I could read a signal and generate a timestamp array.

If there is another method to save my data along with time, then tell me. Still not fully understand Plain Function VI Smiley Frustrated . At this time, I have to measure Response time of my own developed sensor, so data along with time is very important for me.

0 Kudos
Message 16 of 22
(125 Views)

Hi Morya,

 

there are a lot of file functions!

You could try something like this:

check.png

Try to understand what this snippet actually does - before you try to incorporate it in your code! Smiley Very Happy

Best regards,
GerdW
CLAD expired, using 2009SP1 + LV2011SP1 + LV2017 (+LV2018 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink

Message 17 of 22
(122 Views)

Hello sir, if possible, please attach vi files of both examples which u gave in last two reply. I tried searching those function palates, but didnt get it. I am using 2016 version, so drag and use is not possible. One more question. As u last time said, NI-9219 has sample rate of 100 samples/second. So, using express vi (which I attached very earlier), I select no.s of samples = 100 and sample rate =100. But same problem, It skip the samples after every 100 samples. I attached that file. Please check it.

Thank you so much. 

0 Kudos
Message 18 of 22
(102 Views)

wrote:

Hello sir, if possible, please attach vi files of both examples which u gave in last two reply. I tried searching those function palates, but didnt get it. I am using 2016 version, so drag and use is not possible.


Those snippets were done in LabVIEW 2011, so you can drag them into your diagram.  Due to unknown reasons, dragging from the browser does not work.  You need to actually download the png files and then drag them from Windows Explorer.


There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
0 Kudos
Message 19 of 22
(98 Views)
Highlighted

Hi Morya,

 

please attach vi files of both examples … I am using 2016 version

Both are snippets, both are created using LV2011.

You can load them…

 

using express vi (which I attached very earlier), I select no.s of samples = 100 and sample rate =100. Please check it.

Please attach the current state of your VI (or link to the relevant message).

Common hint: get rid of ExpressVIs…

Best regards,
GerdW
CLAD expired, using 2009SP1 + LV2011SP1 + LV2017 (+LV2018 sometimes) on Win7+cRIO
Kudos are welcome Smiley Wink

0 Kudos
Message 20 of 22
(95 Views)