Showing results for 
Search instead for 
Did you mean: 

Measurements not working on remote computer with runtime engine.

Hi all,


I am having trouble with my program working on remote machiens.  I have a DAQ Assist that manages 5 measurements at once, sampled continously.  On the remote machines, no measurements are taken.  However, if I reduce the number of measurements the DAQ assist is performing to 1 measurement, that one measurement is fine.  Sometimes I can take 2 measurements.  The remote machine has the same hardware configuration as the host machine.  When using MAX, everything works properly.  I am running LabView 2009 and my host machine is running Vista while the remote machines have been running either Windows 7 or Windows XP.  Each of these machines only has the runtime engine installed, not the full version of LabView.


Thank you for any help



0 Kudos
Message 1 of 6

Hello hiyakick,


Thanks for posting. Let me get a little more information about your setup.


-What hardware are you using? What are you measuring? What are your sampling parameters (sample rate, number of samples, etc)?

-What are your remote machines? How are you communicating with them?

-How are you determining the behavior of your system (how can you tell what samples you are getting)? What behavior are you seeing?

-If both of your computers only have the LabVIEW Run-Time Engine, what program are you running?


Let me know, thanks!



Joe S.

0 Kudos
Message 2 of 6

-cDAQ 9174 with ni9403, ni9205, ni 9219, 

-measuring current,(tiwce) voltage(3 times) temperature (once)

-Sample continuously 10k is number of smaples and 25k is the sampling rate


-My remote machines are a dell desktop with windows xp on it.  I tried it on a windows 7 laptop also.  I am just putting the program on the computers and installing it, then attempting to run it.


-The behavior of the system is incorrect.  I am looking at indicators directly.  If I do the measurements in MAX it works just fine.   The second more than 2 measurements using the DAQ Assist in the program is ran, the measurements act like they are floating.


-What do you mean by what program I am running?  I have attempted to make an EXE that just did those measurements and it fails to work also.  

0 Kudos
Message 3 of 6



Thanks for your reply.  What versions of DAQmx are you using on your computers?


You said that your DAQ Assistant is configured to take five measurements, but when "more than 2 measurements using the DAQ Assist in the program is ran, the measurements act like they are floating". Does this mean that you are removing some of the measurements from the DAQ Assistant, rebuilding the application and then running the new EXEs on your other machines? Do you notice this behavior regardless of which measurements you remove? In other words, is it always the same two measurements that seem to work normally?


If possible, have you tried running the VI on your host computer with the hardware connected to it to check for the same behavior? This will help determine if the problem exists in the application or in the hardware. Thanks!



Joe S.

0 Kudos
Message 4 of 6

I am using version 9.3 DAQ.  It doesnt matter which two measurements I take, they work when it is 2 or less measurements. 


Yes I have run the hardware on the host machine.  Everything works with the host machine, just not with the remote machine.  


Could it be something with building the application that makes it not work?  I am not an expert of LabView by any means so I may have made a mistake while doing that but I have done it many times in different configurations trying to fix it with no luck.


I have made a simple VI that only makes the measurements and displays the results.  This does work on the host machine, but not on the remote machine when it is an EXE.  

0 Kudos
Message 5 of 6
It's difficult to say what the cause of the issue could be, there are many variables in your setup. We seem to have confirmed that your hardware is functioning normally and that the program you are running seems to work on your host computer. It could be related to how this is being transferred to your other computers.

@hiyakick wrote:


-What do you mean by what program I am running?  I have attempted to make an EXE that just did those measurements and it fails to work also.  

If you said that making an EXE also fails, what was your original method of implementing this program? Do you see the same behavior in each of your methods?


Could you post a screenshot of the "floating" behavior that you are seeing, as well as a screenshot of the program running on the host computer for comparison? Also, would you be able to post a portion of your code that could demonstrate this behavior? Thanks!



Joe S.

0 Kudos
Message 6 of 6