Showing results for 
Search instead for 
Did you mean: 

Malleable Vi Application builder Errors

Go to solution

Dear Community


We were starting using LV2017 and started to use the very nice melleable vi's.

I have found a big problem when using some melleable vi's from the palette and the build an application using the application builder.

In the context of my project i get the following error message when i use the part of the code shown below.

err msg.JPG Full message is this:

Click the link below to visit the Application Builder support page. Use the following information as a reference:

Error 13 occurred at Invoke Node in>>>>>>>>>

Possible reason(s):

LabVIEW:  Failed to load dynamic library because of missing external symbols or dependencies, or because of an invalid file format.
Shareable board exclusively owned.

Method Name: Linker:Write Info To File


Code generating the above error:

code for error.JPGWorking Code:working code.JPG  

I also used the "Number To Enum.vim" from the palette within a different context which lead to the same error.


Please can somebody state if this is only my problem or commonly known ?


Thank you 






Gernot Hanel
IONICON Analytik Gesellschaft m.b.H.
Message 1 of 30

Hi Gernot,


can you post your code? I tried with a very basic VI and it worked without problems, also the building of the Exe. Attached is my code, that was successful in building an exe.

Can you show the wire under your disabled/enabled structure? Only if there was some strange behavior in there....

Cheers, Niko



Niko NR
Systems Engineer, National Instruments
0 Kudos
Message 2 of 30

Dear Nico


Thank you for the response.

The main problem is that this behaviour only happens in the context of two big projects where I am currently not able to seperate the code in a way that it is postable.

Too many dependencies and even special external hardware requirements to run properly.


I go on vacation next week.

I will try to shrink my code to a minimum to post it including the problem after my vacation.

As I use the workaround currently it is not to urgent.



Gernot Hanel
IONICON Analytik Gesellschaft m.b.H.
0 Kudos
Message 3 of 30

Dear Gernot,

good that you have a workaround in the mean time. Let me know if you can reproduce the error with my code snippet or you can shrink down your code to a minimum size so I can test it on my side.



Niko NR
Systems Engineer, National Instruments
0 Kudos
Message 4 of 30

When I added the following to my VI, it would not build correctly. I am using other malleable VIs, including home-brewed ones, and it does build correctly. Once the malleable VI below was removed, the VI built correctly into an exe.







Message 5 of 30

Here's another VIM that caused the same problem.




Interestingly, when I converted it to a "real VI", the problem did NOT disappear and the same error occurred.



0 Kudos
Message 6 of 30

Has NI worked on this?  I am experiencing a similar error in building in 2017, though I haven't narrowed down the source yet (but I have started to use VIMs).


Error 13 occurred at Invoke Node in>>>>>>>>>>>

0 Kudos
Message 7 of 30

Issue traced to the "Is Value Changed.vim" Malleable VI.   Confusingly, though, I have another VI that call this VIM that CAN be built without error.  Also, simple VIs made to try and reproduce the issue build fine.  So there must be an interaction between the VIM and some other feature of the VI being built.

0 Kudos
Message 8 of 30

Made my own "On Change" VIM, that has the same internal code as "Is Value Changed?" but was made from scratch.  Using this doesn't seem to cause a problem.

Message 9 of 30

Sometime if you e.g. drop property nodes that break the code the error is pointed out at a completely different place, i guess some error propagates in the wrong order. Could this be something similar?



G# - Award winning reference based OOP for LV, for free! - Qestit VIPM GitHub

Qestit Systems
0 Kudos
Message 10 of 30