Showing results for 
Search instead for 
Did you mean: 

MS Office Report, too many dimensions



I'm trying to add some code to a program I wrote for Diode Testing. Basically I want the program to run thru the tests and then send the data to Excel automatically. I was able to use the configure MS Office report function in labview to do this, but it will only work if I use a String or a double. Neither of these works for what I'm trying to do as I have negative datapoints and have them linked to formulas. When I try to select integer and run the program it gives me an error saying "Report Generation Toolkit: You cannot use arrays with more than two dimensions.". I've spent about 2 hours looking thru my code today and cannot find any location where I have an array of Dimension 3. I've attached my code. Also note that I am only using the case 1 after the boolean for testing purposes, the other cases have code, but it needs to be changed still so can be ignored.


Any help would be greatly appreciated!,



0 Kudos
Message 1 of 3



The file you attached is missing some subVIs (Instrument Control VIs?) and global variables, so I can't run your program to recreate the error.  Please post your error code number, that would help in moving forward.  Also have you tried placing probes?  If you place probes on the input wires of all  your arrays you can monitor what is passing through the wires as inputs.



Peter T
Applications Engineer
National Instruments
0 Kudos
Message 2 of 3


I think I figured out the problem, because the spreadhseet had string variables it was messing everything up when I tried to use it as an integer spreadsheet. In the end I was able to get the output to come out correctly in string form by delimitting it with a tab.





0 Kudos
Message 3 of 3