LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

MS OFFICE REPORT vi / ERROR-41110

Solved!
Go to solution

Hey there !

 

I'm new on labview but i'll try to give you as much details as possible.

 

To give a bit of context to my trials, my goal is to realise a DAQ system that generate an excel report which is created from a template.

For this, I'm currently simulating my DAQ system with the Simulate Signal vi. then i apply tone, spectral and amplitude measurement to get multiples data.

Finals step, I send theses acquired data as well as the signals simulated into the MS Office report vi to generate my report.

 

And here's my issue.

I made multiple trials but didn't find a solution yet.

When using the basic report for excel provided in the MS Office vi to store the data and generate a report, we canf find in this example, various type of data and different solutions on how to save them.

it works perfectly with my solution, i was able to save and plot my signal, got access to all data points and was well displayed.

I then try to use this template as a reference to create mine.

Made mine, use same fields and type of datas...everythings looks really the same than the NI template.

But i can"t store and display data points from my generated signals and got error 41110 code

String value work, i can display my signal...but can't find a solution to get an array with data points.

I tried to "cast" the data points format to string but didn't fix it.

Using other VI, like write to measurement file, allows me to get those data points, but i can't use a dedicated template.

RedCrows_0-1715874513822.png

error is displayed on AmplitudeMeasured but it's not the case. this value is correctly stored but the following one, my 2d array table is creating this error.

RedCrows_1-1715874599129.png

 

To sum-up, my issue is : I can't save data points in an excel file using MS Office report VI and my personnal template

 

Find attached my excel template and labview vi.

 

Thanks in advance

Download All
0 Kudos
Message 1 of 8
(421 Views)

RedCrows_0-1715875227129.png

forgot to add details and version of labview used

0 Kudos
Message 2 of 8
(418 Views)

The error message explains the problem.  You do not have named ranges in your Excel file, meaning LabVIEW doesn't know where to put the data. 

aputman_0-1715878113588.png

 

Edit: Unfortunately, I can't open your VI. 

 

 

 

aputman
------------------
Heads up! NI has moved LabVIEW to a mandatory SaaS subscription policy, along with a big price increase. Make your voice heard.
0 Kudos
Message 3 of 8
(398 Views)

Thanks for your answer.

 

I wouldn't have a post a message here if i havn't check this already.

I do have names ranged in my excel template. it works for some of referenced cells but not for some others.

that's where my issue is.

RedCrows_0-1715879110567.png

My excel is in French but here is the name management tab that reference all the named range.

all my "containers" are named and 90% works fine.

Only when i want to write data points from my signals... probably because it should extend the pre defined size or i don't know.

RedCrows_1-1715879250475.png

 

I uploaded a saved version under 2012 edition here after

 

0 Kudos
Message 4 of 8
(388 Views)
Solution
Accepted by topic author RedCrows

The named range doesn't exist on the main worksheet.  The express VI doesn't change worksheets.

aputman
------------------
Heads up! NI has moved LabVIEW to a mandatory SaaS subscription policy, along with a big price increase. Make your voice heard.
Message 5 of 8
(385 Views)
Solution
Accepted by topic author RedCrows

I've used the Report Generation Toolkit for more than a decade, but have never used the MS Office Report express VI (I generally avoid Express VIs).  I made a "Revised Generate Excel Report" post here a decade ago (start typing what I put in quotation marks in the Forum's Board Search Bar and you'll find it) that shows how to put multiple things on a WorkSheet (including a graph) -- it worked then, and it works now.

 

If you want to use multiple WorkSheets, there are Excel-specific Functions in the RGT that will let you do that, too.

 

Bob Schor

Message 6 of 8
(360 Views)

Hey !

 

Thank you for your answer, it explains why i couldn't do such things with my templates.

 

I'll try to think to another solution to be able to also store my data points.

0 Kudos
Message 7 of 8
(342 Views)

Hello Bob,

 

thank you for your reply, i'll give a look to your solution.

 

0 Kudos
Message 8 of 8
(340 Views)