LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

MODBUS RTU Communication with a VFD (Sure Servo by Automation Direct)

Tried that too, still no luck. 

 

Capture.PNG

Capture1.PNG

0 Kudos
Message 11 of 17
(433 Views)

As a sanity check, if you physically disconnect the Serial line it does error, right?

0 Kudos
Message 12 of 17
(421 Views)

I just tried that and "NO ERRORS" Everything looks just the way it is. i dont understand what is going on???

0 Kudos
Message 13 of 17
(415 Views)

I would suggest taking a step back and starting to debug one element at a time:

 

  1. Does the RS-485 converter work correctly? Can you connect its Tx and Rx pins and see that you get what you type back in a terminal (Termite, HyperTerminal, a LabVIEW serial example, etc.)?
  2. Do you have another RS-485 device which you can talk to verify that.
  3. Can you try a Modbus client that's known to work (an external Modbus client, a LabVIEW example, etc.) to check if you can talk to the VFD? See if you can get back any values at all.
  4. Maybe the VFD needs to have something configured to work with Modbus? Search the manual for Modbus and make sure. Can you get support from the manufacturer/seller?

___________________
Try to take over the world!
0 Kudos
Message 14 of 17
(370 Views)

HI  @tst

 

Thanks  for writing and helping out. 

So i tried what you have wrote.

 

1. RS485 adapter works fine. Checked the adapter with a different device and it connects to the device toolkit software.

 

2. I tried communicating with a Stepper motor drive (Not the one i am having problem with) which has RS485 enabled, but i couldn't set up comms with it. (Attached VI that i used to comm with the Stepper Motor Drive)

 

3. Tried using various VI examples from the forum and other examples from LabVIEW to see some sought of comm with the VFD but there is no results. I don't see any comm between LabVIEW and VFD.

 

4. I am thinking the same too, The VFD might have some RS485 enable function that i am missing. I pretty much went over the manual and i couldn't find anything relating it. I have contacted the manufacturers tech team about the same and I'm awaiting response.

 

I have used the attached program to comm with a temp calibrator via RS232 and it works fine. Cant i use the same program for an RS485 device comm too?

 

Thanks,

themadgreek

 

 

0 Kudos
Message 15 of 17
(355 Views)

@themadgreek wrote:

 

I have used the attached program to comm with a temp calibrator via RS232 and it works fine. Cant i use the same program for an RS485 device comm too?


I can't open the code, so as a more general response:

 

  1. Both RS232 and RS485 are serial protocols, so they should work using the same API (probably VISA in your case).
  2. Different devices use different protocols, so unless you're using something which uses the same protocol (presumably Modbus RTU, in this case), then the code would need to be modified. Even if I are using the same protocol, there might be differences (for example, they might use different registers and not respond to commands which work with the registers from the other device). I don't know what your devices do and what your code does, so I can't comment specifically.
  3. Because RS485 has multiple devices on the wire, the protocol usually requires that the master also sends some kind of identifier to let the devices know which device the message is for. In Modbus this should be covered by the device ID.

 

 

Like I said, I would suggest using a Modbus master program that's known to work, at least for testing. That way you at least take your code out of the equation.


___________________
Try to take over the world!
0 Kudos
Message 16 of 17
(334 Views)

Hi,

 

So i finally got the servo driver to comm with LabVIEW. The problem was that the manual specified the RS485 connection as a 4 wire connection, so i got in contact with the manufacturer tech team and they said its 2 wire configuration as the Rx and Tx are jumpered internally and the manual had no reference of it. So i did the connection in 2 wire and it started working. 

 

Thanks,

themadgreek

0 Kudos
Message 17 of 17
(317 Views)