Showing results for 
Search instead for 
Did you mean: 

Looking for fix to Database Variant error issue 459AA98Z

I've updated a large application from LV 7.1 to LV 8.2.  The application uses a number of toolkits, including the Database Connectivity Toolkit.  I have been stung by the Invalid pointer error -2147467261.  In LV 7.1 the program would convert an empty variant into a 0, but with LV 8.2 it gives an error. 


I found reference to this bug as issue 459AA98Z, but no workaround was listed.  That was about a year an a half ago.  Is there any fix for this? 


I have more than 50 vis, accessing something like 20 tables in two different databases, to which I will need to apply some sort of fix.  Did a later version of LV fix this problem?   


The only programming fix I have thought of if there is not a fix from NI is to change each of these vis that has a query that might come back empty.  I would change the vi to actually have two queries, the first query would ask for the count of records that meet the criteria I will be selecting on.  If the count comes back as 0, I would not do the query and return empty data.  If the count comes back greater than 0, I can proceed with the query and get the data.  Let's just say I'm not looking forward to making this change to so many vis that I would have to change.   Does anyone have any better suggestions?


Nancy Backes

0 Kudos
Message 1 of 7



          The bug was fixed with the release of Database Connectivity Toolkit 1.0.2. LabVIEW 8.6 also helped fixed other bugs dealing with Database pointers. I hope this information help. Thanks!!

0 Kudos
Message 2 of 7



          Here is a list of LabVIEW 8.6 bug fixes (just search the document for Variant to see all the changes). The bug fix in the Database Connectivity Toolkit can be confirmed in this document that gives information on the 1.0.2 toolkit and points to the 1.0.1 bugs (most have been fixed and the ones that haven't are listed in this document). Thanks!!

0 Kudos
Message 3 of 7


Thanks for the information.  I didn't see anything in the LV 8.6 bug fix list that specifically refers to this problem but there are other potenitally useful fixes. 


I didn't see anything where it specifically says that this problem was fixed in the DB connectivity toolkit 1.0.2.  Do I understand you correctly that you are saying if it was a bug from 1.0.1 that it was fixed unless it is still called out in the "known issues" section of the notes for version 1.0.2?


I will have to check on the update to this toolkit.  I am on SSP for my LV license, do you know if that would cover this toolkit also?



0 Kudos
Message 4 of 7



         Yes. Your bug was specifically fixed with the 1.0.2 release. I can't point you to our CAR files because you don't have access. The Read Me files are used (in a round about way) to let you know what bugs are fixed. Because yours isn't on the list, it was fixed (I have it from other people though that it has been explictedly tested and proved to be fixed). Good Luck!!

0 Kudos
Message 5 of 7

Grant, not to hijack the thread but I have a question/bug report about the Insert Data VI.  I am also using DBToolkit 1.0.2 and LabView 8.6.


When I use it with an array of columns and an equal size array of values the VI fails and returns error 1.  Doing a bit of digging, it appears that a confilct between how the parser generates the parameters and how the Build Insert Query wants to see an array of parameters matching the size of the column array.  Since the parser builds a single element array, the parameter array size does not match the column array size, thus causing the error.  I haven't tested this, but using a string for the values and a column array will generate the same error, as the same path is taken by the values data. 


Wondering if this has been noted by NI and is scheduled to be fixed?  My use of arrays for columns and values would simplify my code greatly since my data being written to the data base is variable in column count depending on the DUT. 

0 Kudos
Message 6 of 7



I know that VI is expecting a cluster of elements for the Data input, and will throw error 1 when you pass it an array. Have you tried converting your array of values into a cluster before you pass it in? 

0 Kudos
Message 7 of 7