LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Loading S/W onto PXI chassis RTOS via MAX

Solved!
Go to solution

I have a PXI chassis with LAbview 2016 RT OS on it along with Windows 7. When powering on the PXI chassis, I get a message that "No Software is installed". When I try to intall software via MAX from a remote laptop, I get the following message. Can someone tell me what this means? If I have to install the software locally (i.e boot the PXI chassis into WIndows), where do I install the software (C:\ drive, which has Windows or the D:\ drive, which has the RT OS on it)?

Max_Error.png

0 Kudos
Message 1 of 9
(2,079 Views)

Sorry, your embedded PNG was too small for me to make out any detail or read the error message.

 

Some questions:

  • You say that the PXI Controller has LabVIEW RT-OS and Windows 7.  Does that mean you can plug in a keyboard, mouse, and display to the Controller and it will boot up into Windows 7?
  • Has it ever worked as a LabVIEW RT Target, or did it come configured this way and never worked as a Target?
  • I'm not "up" on what the latest is for PXI Controllers, but my understanding (possibly outmoded) is that the RT-OS requires its own bootable Partition and cannot (easily) co-exist with Windows (except in a Dual-Boot configuration).  In any case, I always configure my PXI Controllers as "Pure LabVIEW RT systems", starting from a reformat of its Hard Drive, if necessary.
  • What Controller are you using (something else I couldn't tell from the PNG)?

Bob Schor

 

P.S. -- Here's a screenshot of one of my PXI systems with an 8108 controller running LabVIEW RT 2016 (I didn't expand the Software tab -- it would take several screens).

Remote Systems.png 

0 Kudos
Message 2 of 9
(2,057 Views)

Thanks bob for the quick reply:

Answers to your questions:

1. Yes, I can plug a keyboard, mouse and display into the controller and boot into Windows 7

2. Yes, it has worked before. I understand why I get the "no software installed message". That is an issue with my Labview code.

3. The controller is partitioned. The 'C' drive has Windows installed and the 'D' drive (Fat32) has the RT OS installed

I ahve ahd this haapen before and was able to reinstall the software via MAX. The "devices and Interface' tab does not expand and when I right click on the software tab, I get the below message. It seems there is a file missing that MAX uses to populate the devices and software tab.

 

MAX-Error.bmp

0 Kudos
Message 3 of 9
(2,051 Views)

Am I correct that when you are trying to get MAX to "see" your dual-booting controller that you have already booted the Controller so that it is running on the 😧 (RT-OS Fat32) partition?

 

Are you able to get your PC (running, I presume, Windows) to see the Controller as a "Network Place"?  Do you know how to set this up?

  1. In Windows Explorer, right-click on your PC's Icon, choose Add Network Location.
  2. Start the Wizard.
  3. Choose a custom network location.
  4. Specify ftp://<IP of your PXI Controller>

If your controller is booted into the 😧 partition, this will give you direct access to that partition.  You'll be able to see the RT-OS files and folders, as this screen shot demonstrates.

PXI FTP.pngBob Schor 

0 Kudos
Message 4 of 9
(2,045 Views)

Bob,

 

Yes, Controller has booted into RT OS.

I have been able to boot the controller into Windows, open MAX locally from windows and see the software and devices.

From looking through MAX locally, it appears that all of the RT S/W is installed on the 'C' drive but I am not 100% sure.

My understanding is that the S/W is installed on the PXI chassis but the drivers have somehow been removed from the chassis. When MAX is ran remotely, it is the drivers that are getting reinstalled and not the complete RT OS software package. Not sure what files I should be verifying are installed on the PXI chassis.

0 Kudos
Message 5 of 9
(2,036 Views)

Here's the deal -- a PXI Controller runs a single Operating System, either Windows (if you are not doing anything that requires Real-Time) or a Real-Time OS.  The two different systems even live on two different disks -- Windows on an NTFS disk, the RT-OS on a Fat32 disk.

 

You cannot run both at the same time!  [I just realized that there is a possibility that I'm sufficiently "out of date" that the following statement might no longer be true, but for now, I'm going to assume it is correct].  This means, among other things, that you cannot use MAX running on the Windows part of the controller to interrogate the RT-OS that is not running on the same controller.

 

At one point, we had a dual-boot PXI controller that came up in Win2K (yeah, a few years ago) and LabVIEW Real-Time 7.0.  After a few problems getting the software properly updated, I reformatted the hard drive and installed the RT-OS.  Since then, I've built about a dozen PXI controllers (sometimes "rebuilding" them, upgrading the OS, replacing a failed hard drive), and I only install the RT-OS.  After all, I have a perfectly good Windows PC on which I develop the LabVIEW Real-Time software, and which can serve as the Host in the Host/Remote model of the LabVIEW Project (with the PXI, of course, being the Remote).

 

If you are developing on a "real" PC, my recommendation would be to make the PXI Controller an "RT-Only" machine, starting with reformatting its hard drive to FAT32 and doing a fresh install of the LabVIEW RT Software.  Develop on a PC (you don't need the PXI connected to develop code for it), test with a PC connected to a PXI, and run with the same (or another) PC connected to the PXI.

 

Bob Schor

0 Kudos
Message 6 of 9
(2,030 Views)

Bob,

 

As I have researched this more, I am wondering if I need to reinstall the PXI Platform services software. It appears this software is what is used to recognize the PXI chassi, Devices and software. The below isan excerpt from the NI websire relative to this software

 

"This software is required to identify NI PXI and PXI Express chassis and modules, as well as to allow for trigger routing. The proper hardware driver for particular NI modules such as DAQmx products is still required to fully leverage its capabilities. NI PXI Platform Services is already included with hardware drivers, but there may be cases where only the PXI Platform Services software is needed for certain applications. Some example scenarios include the use of NI-MXI products or the use of NI PXI or PXI Express chassis without the installation of other NI PXI hardware drivers. Contact ni.com/support with questions related to this"

0 Kudos
Message 7 of 9
(2,016 Views)

Well, I've never explicitly installed NI Services, but just accepted what came along with I installed LabVIEW.  I can tell you that I currently have 16 NI Services running on my Development PC (which can "see" my PXI), including PXI Resource Manager, Service Locator, NI-DAQmx Remote Configuration and Development, etc.  Let me see if I can capture them ...NI Services.png

 

Bob Schor

0 Kudos
Message 8 of 9
(2,008 Views)
Solution
Accepted by topic author Jeff1962

Bob,

 

Thanks for the help.

Ultimately, had to reformat the controller drive and that took care of the issue.

 

0 Kudos
Message 9 of 9
(1,964 Views)