Showing results for 
Search instead for 
Did you mean: 

Lavbiew Save Error code 3:FP heap

I got lucky!  I found the cause of my problem.  A graphic that I copied from a powerpoint slide and pasted onto a tab control was apparently the culprit.  I have several other graphics from the same ppt that work fine, and I can't remember exactly how I did the copy/paste - I may have saved as a GIF file first.  The file size with that "bad" graphic was 1613 kb, without it is 1128 kb.  I still don't know when or why it was corrupted, and why it started causing the write errors, but perhaps it is another clue.

0 Kudos
Message 21 of 23

In my experience, it had something to do with the runtime shortcut menu.


When I faced this error, I tried many things including changing OS. Finally I found that the problem was with a waveform graph. It had a runtime shortcut menu which was saved into a .rtm file in a particular folder. Later I had renamed that folder. Because of that, Labview was unable to load it.

When I recreated the shortcut menu from the graph, problem solved.




0 Kudos
Message 22 of 23

I got this message last year and it caused me a whole mess of trouble... I had to just load an old version of the program and re-do the same changes I had made. Then it saved fine.
Today I had the same problem with the same VI, but all I had changed since the last save was a subVI. So I just closed the main program and re-opened and it saved just fine.

This error just seems to come up occasionally at random. The only solution seems to be saving often and loading an old version when it stuffs up...
Not very satifying though...

0 Kudos
Message 23 of 23