Showing results for 
Search instead for 
Did you mean: 

Labview "hung up" when launching TeraTerm program using System



This is probably low hanging fruit for most of you. I am using LabView 2010 BTW. So I launch TeraTerm using the system but labview gets "hung up" in the run position. Standard inputs can be seen in the attached image. I use the same exact manual method by opening up cmd.exe with no problems. In all actuallity even using the TeraTerm launches just fine. It's just the labview progarm itself that hangs up in the run position. I've noticed in Task Manager that labview is drawing about 99% of my processor during this process. It's like it won't release.


Any help would be appreciated. And before anyone asks Smiley Happy yes I do need this functionality. It will be programmatically controlled at a higher level (test stand) to supply a user with a "debug" mode for my specific application. So launching TeraTerm, which is sniffing (listening) a receive line is needed for certain circumstances. And BTW I have checked, and no other comm ports are being used.


Again, any help would be nice. I know not a lot of information, but I'm sitting here thinking if there's anything else and I can't think of anything. It's a new computer, only 2 comm ports being used, I open up external apps with system all the time. Maybe I'm having "a moment" here :).


Best Regards,





0 Kudos
Message 1 of 5

I call TeraTerm from inside LabVIEW from within TestStand, but I have to close the com port from within inside LabVIEW before I call TeraTerm. Then once TeraTerm closes (returns to LabVEIW) I then reopen the comport.


Are you trying to have both LabVIEW and TeraTerm open the same comport?


There are some comport monitor software that will "sniff" (display com traffic) but you need to have them in place and running before you run LabVIEW. 

0 Kudos
Message 2 of 5



Thanks for the reply. I actually don't think it's a comm port issue. I just tried changing the system to launch roxio and it does the same thing. For some reason labview is "hanging on" in the run position until the external application being called is closed. My issue is I need the external application (teraterm) to remain open and for labview to "complete" it's run (i.e system


At this point, comm4 is doing nothing, it is closed prior to launching system I'm not even asking teraterm to do anything at this point. I just need system to open teraterm (which is does now) and not get stuck in the run position.


Do you see anything wrong with the syntax maybe? The standard output of the system does look exactly how it does if you manually launch teraterm from cmd.exe


Question!! When you launch system to open teraterm does the labview program complete its run (not get stuck). Or do you do whatever you have to do in teraterm then kill it.


Thanks again,



0 Kudos
Message 3 of 5


wait until completion? (T)


Set this to false

0 Kudos
Message 4 of 5



Okay, so I knew that wouldn't work cause I already tried, but it DID force me to stop and think. Since the wait until completion when false disables your standard input it forced me to realize that my command line is where my FULL argument needed to be. Geez, talk about a "moment". Been working with too many .bat files 🙂


Thanks again.



0 Kudos
Message 5 of 5