LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview hangs for 30 sec after first VI opened

Solved!
Go to solution

Is anyone else seeing this issue? When I run the Labview development environment and open any VI (including a New VI), I get an hourglass cursor and am locked out of clicking anything for 20 to 30 seconds. I see this behavior on multiple computers. Then I don't see the behavior again while Labview is running.  Pretty annoying!  I'm running Labview 2015 SP1 f10 on Windows 10 or 7.

Thanks.  -Joe Czapski

------------
Joe Czapski, Sonos, Boston, Mass.
0 Kudos
Message 1 of 8
(2,225 Views)

As I recall LV2015 was that way, and it was very annoying.

 

 

========================
=== Engineer Ambiguously ===
========================
0 Kudos
Message 2 of 8
(2,213 Views)
Solution
Accepted by Station3

By default, LabVIEW "pre-loads" all palettes in the background, causing this to happen.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 3 of 8
(2,177 Views)

Thanks, Bill, looks like it was the palettes loading. Under Options I changed from "Load palettes in background" to "Load palettes when needed", and now I don't get the hourglass when I open the first VI.

 

Now why would "background" loading lock me out of all actions for up to 30 sec? In computing, background processes are supposed to invisibly run without taking too much resources away from the visible apps. Also, I've used the background setting for many years, but the hourglass problem has only recently appeared for me, hmmmm.

 

Thanks again,

Joe

 

------------
Joe Czapski, Sonos, Boston, Mass.
0 Kudos
Message 4 of 8
(2,153 Views)

@billko wrote:

By default, LabVIEW "pre-loads" all palettes in the background, causing this to happen.


And for some reason LV2015 was very bad at doing this as I don't recall 2014 or 2016 and newer having that issue..

========================
=== Engineer Ambiguously ===
========================
0 Kudos
Message 5 of 8
(2,142 Views)

@RTSLVU wrote:

@billko wrote:

By default, LabVIEW "pre-loads" all palettes in the background, causing this to happen.


And for some reason LV2015 was very bad at doing this as I don't recall 2014 or 2016 and newer having that issue..


Yeah, with LV 2014, it only takes a few seconds.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 6 of 8
(2,130 Views)

@Station3 wrote:

Thanks, Bill, looks like it was the palettes loading. Under Options I changed from "Load palettes in background" to "Load palettes when needed", and now I don't get the hourglass when I open the first VI.

 

Now why would "background" loading lock me out of all actions for up to 30 sec? In computing, background processes are supposed to invisibly run without taking too much resources away from the visible apps. Also, I've used the background setting for many years, but the hourglass problem has only recently appeared for me, hmmmm.

 

Thanks again,

Joe

 


I don't know why it would for 30 seconds, but I know why it would lock you out while it's loading.  I'm guessing they don't want a user to be opening the palettes while they were still loading.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 7 of 8
(2,128 Views)

@Station3 wrote:

Thanks, Bill, looks like it was the palettes loading. Under Options I changed from "Load palettes in background" to "Load palettes when needed", and now I don't get the hourglass when I open the first VI.

 

Now why would "background" loading lock me out of all actions for up to 30 sec? In computing, background processes are supposed to invisibly run without taking too much resources away from the visible apps. Also, I've used the background setting for many years, but the hourglass problem has only recently appeared for me, hmmmm.

 

Thanks again,

Joe

 


Unless they use non-reentrant components that are also not thread safe and require the UI Thread to execute serially 😉

Just saying

A Solid State Hard drive helps a lot.  (I Wish I had one)

 

Meanwhile loading pallets as needed rather than suffering the cost on launch just pusses the problem out to the first time you hit Ctrl+Space.


"Should be" isn't "Is" -Jay
0 Kudos
Message 8 of 8
(2,122 Views)