LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview cannot find NI ELVIS II Libraries called from Multisim 14.1 NI ELVIS template

We are using Multisim Educ v 14.1 with no problems on Win 10.  Recently acquired a NI Elvis II+ and installed ni-elvismx v19.0 and Labview 2020 (community version).  The Elvis tools work fine.  Tried to follow the example on the NI Multisim ELVIS example page (https://www.ni.com/en-us/innovations/white-papers/12/teach-analog-circuits-with-ni-multisim-and-ni-e...) and after selecting NEW and trying to open the NI ELVIS II template, we get a string of error messages from Multisim that the respective NI-ELVIS LIB files cannot be found by Labview version (18).  Pictures attached.  We checked and all the LIB files are in the path being shown in the error messages plus we don't have Labview 18 installed only Labview 2020 (community) and Labview 14.1  Can anyone offer advice?  Should I reinstall everything in a specific order??

 

TIA

0 Kudos
Message 1 of 4
(132 Views)

Hello,

  I suppose you do not have to reinstall everything. This has happened before and I am suspecting that there might be something wrong with the driver.

I suggest you to try download and reinstalling the NI ELVIS driver again and update me on wether the reinstallation made it work. 

In case you need the address link to download the driver, you can refer this link : NI ELVISmx

Also, you can find different templates that can be used with Multisim from the links at the bottom of the page you provided in your ticket. 

Best,

Fiona,NI

0 Kudos
Message 2 of 4
(80 Views)

Thank you, I tried reinstalling drivers, then did an entirely new installation on a laptop and same problem.  I searched and found compatibility tables on the NI site and it seems that NI ELVIS II and Multisim 14.1 only work with Labview 2015 or 2016.   Fortunately I had a licensed copy of Labview 2016 buried on one of my backup drives and after installing it I found that ELVIS II+ now plays nicely with everything.  I did an experiment and uninstalled LV 2016 and put back LV 2020 and that again didn't work, so definitely a LV version issue.  Regrettably, the  current version of the Circuit Design Education suite still is 14.1, but LV 2015 and 2016 are not available unless you have a SSP license and the cost of that is prohibitive for a solo student like me. 

0 Kudos
Message 3 of 4
(69 Views)

Sorry to hear that you have to reinstall an older version of labview to use NI ELVIS II, but I am glad that you have your issues resolved.

I just did the same search and found that ELVIS II is an older version and  so it is normal that the newer versions of LabVIEW can no longer support it.

NI actually released ELVIS III which can be opened with LabVIEW 2019 and a newer version is to be released too.

Anyway congrats on having your problems resolved.

Best, Fiona

0 Kudos
Message 4 of 4
(47 Views)