LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview cannot check out a license from the VLM

Hello,

I have a user with Labview v7.1 Pro that was working and checking out a license from the VLM v2.0 server but for some reason now, he can not check out a license and he gets an error.  He indicates nothing has changed on his side.  Yet, when he attempts to run Labview, I do not see any activity within the lmgrd.log file.  I would think it would appear in here.

Can someone please contact me to discuss this problem?  If activity logs or other information is needed, I can provide it at that time.

Thank you,

Rob Sevick

(443) 778-7854

0 Kudos
Message 1 of 11
(3,504 Views)
Highlighted
Hi Rob,

In order to see any activity in the lmgrd.log file, you need to make sure that you have the debug log on for VLM.  You cna find directions for doing this here.  Also, please walk through these typical debugging steps for NI Vloume License Manager which you can find here.  Let me know what you find from these actions.
Also, if you would like to talk directly with support here at NI, you can call 1-866-275-6964 to talk with Technical Support.
Thanks,
Caroline Tipton
Data Management Product Manager
National Instruments
0 Kudos
Message 2 of 11
(3,473 Views)
Highlighted
Hi Caroline,
 
The client is trying to connect to the current license server (as specified in your instructions) and the debug log is turned on and has been.  In looking at the debug.log file, it doesn't even register this computer as attempting to connect, which is strange because the user indicates it was working.  The computer is alive on the network and I can communicate with it.  Any other ideas besides reinstalling the client.
 
I just submitted another post regarding the removal of Permission Requests in the VLM.  If you have a chance, please review that one as well. 

Thanks,

Rob Sevick

0 Kudos
Message 3 of 11
(3,449 Views)
Highlighted

More information...

The user is connecting to the license server properly and this (below) is logged in the lmgrd.log file on the license server.  I tried adding the user to the VLM but this did not help.  I confirmed the case on both the user and computer name but still no luck.  The user indicates the message on his client when he tries to run it is (something like), "No licenses left and/or feature expired"  Any ideas?  Should he reinstall this version?  I can forward the activity log (encrypted) and/or the lmgrd.log file if you like.  Thanks,

12:59:36 (nilm) DENIED: "LabVIEW_FDS_PKG" greendg1@VIA-Chassis2  (User/host not on INCLUDE list for feature. (-39,349:10054 ""))
12:59:36 (nilm) DENIED: "LabVIEW_LabVIEW" greendg1@VIA-Chassis2  (User/host not on INCLUDE list for feature. (-39,349:10054 ""))
12:59:36 (nilm) DENIED: "LabVIEW_PDS_PKG" greendg1@VIA-Chassis2  (All licenses are reserved for others. (-101,396:10054 ""))
12:59:36 (nilm) DENIED: "LabVIEW_LabVIEW" greendg1@VIA-Chassis2  (All licenses are reserved for others. (-101,396:10054 ""))
12:59:36 (nilm) UNSUPPORTED: "LabVIEW_LabVIEW_Debug" (PORT_AT_HOST_PLUS   ) greendg1@VIA-Chassis2  (License server system does not support this feature. (-18,327:10054 ""))

0 Kudos
Message 4 of 11
(3,440 Views)
Highlighted

Hey Rob,

I have another customer with this same issue and I am looking into it for you.  I will post as soon as I find the answer.

Regards,

jigg
CTA, CLA
teststandhelp.com
~Will work for kudos and/or BBQ~
0 Kudos
Message 5 of 11
(3,420 Views)
Highlighted

Hi Rob,

Thos are actually FLEXlm error messages.  Here  is a good document about using FLEXlm with VLM.  Basically you need to edit the .opt file to allow access to that specific user.  The nilm.opt file is found in this directory: C:\Program Files\National Instruments\Volume License Manager.  I hope this is helpful.  Here  is a link to all the FLEXlm error codes.

Regards,

Message Edited by Sam R on 01-10-2006 04:50 PM

jigg
CTA, CLA
teststandhelp.com
~Will work for kudos and/or BBQ~
0 Kudos
Message 6 of 11
(3,410 Views)
Highlighted

Hey Rob,

Sorry that last post is a little wrong.  If you are using FLEXlm then you edit the .opt FLEXlm file.  If you are using VLM then you can reject or allow permissions to the computer and it will automatically update the nilm.opt file.  So the computer that is putting these errors in the log file does not have permissions for the application it is trying to run.  It may have permissions for other apps but not this one.

Thanks,

jigg
CTA, CLA
teststandhelp.com
~Will work for kudos and/or BBQ~
0 Kudos
Message 7 of 11
(3,398 Views)
Highlighted

Sam -

I am using the VLM for permissions.  You confirmed my thoughts about rejecting/allowing, will automatically update the nilm.opt file.  I still don't know why this particular user/computer cannot run Labview/Developer suite.  I assume the license is backwards compatiable, correct?  He is running the previous version of Developer Suite Pro.  For the time being, here is what I suggested to him (let me know what you think):

- Uninstall whatever (and all) versions of LabView / Developer suite you have on this system VIA-Chassis2

- Delete the folder and all files under: C:\Program Files\National Instruments

- Reboot

- Install the version of LabView. I currently have this computer licensed for: Developer Suite.

- Reboot afterwards if prompted.

- Run it and let me know what happens. I can then check the logs and if there is a problem, forward that to NI.

Let me know what you think and if there is anything else I can do.  I'll let you know how this goes.  Hopefully his install was simply confused or corrupted and was not successfully communicating with the license server/VLM.

Thanks,

Rob Sevick

0 Kudos
Message 8 of 11
(3,391 Views)
Highlighted
Hey Rob,
 
I am curious to see if that will help.  The thing is that it looks for the exact version in the .opt file.  So I don't know if he was trying to run a different version or whatever and didn't have permission for that version.  I was also checking your file and you have Premier support so if you didn't want to do the discussion boards you could email us directly or call us.  Here is the link to the support page: http://www.ni.com/support/  It has all the information about our support.  Either way is fine with us though. 
 
Regards,
jigg
CTA, CLA
teststandhelp.com
~Will work for kudos and/or BBQ~
0 Kudos
Message 9 of 11
(3,384 Views)
Highlighted

Hi All,

 

Any solution was given for this issue ?

 

Thanks and Regards,

Prajesh Hegde

0 Kudos
Message 10 of 11
(1,108 Views)