Showing results for 
Search instead for 
Did you mean: 

Labview Siglent 1052dl Scope Connectivity Problems


I am not sure if this question belongs here or on the thread related to usb/serial ports, but I will post it here first.


I have a siglent 1052dl scope connected to my computer. I am running a BK 4052 signal generator to an amplifier, which the scope then reads the voltage output from the amp. The correct signal shows up on the scope screen. I am trying to get the scope to read and store the output (this I know how to do), however when I attach the scope to my computer it does not recognize the scope. 


I have used both USB-A to USB-B ports from the scope to my computer as well as an RS-232 to USB adapter. I have checked in device manager with both plugged in to make sure the location is correct and it is not the port that is the problem. I have also tried each one in all of my usb ports. When I select the VISA Resource Name in labview the name is "COM3", but when I run the collect waveform program I get errors. First I got this error Error 1: labview error code -1073807343. After some more attemps I got tis error Error 2: visa (hex 0xbfff0072). Now I am getting this error Error 3: LabVIEW:  An input parameter is invalid. For example if the input is a path, the path might contain a character not allowed by the OS such as ? or @.


I have used NIMAX  to try and open a test pannel but when I select open test pannel the message given is:

Error opening resource:

VISA: (Hex 0xBFFF0072) The resource is valid, but VISA cannot currently access it.


When I go to VISA Interactive control I either get the device showing up as "Unkown" with the location "ASRL3::INSTR" or it will show up with as "ASRL3::INSTR" location as "ASRL3::INSTR". There is no pattern to which shows up when.


I would have tried further debugging on the code however the code does not run as I get the error message right away, I am also simply using the official labview examples at this point to ensure that the error is not within my colection code. I hope I have provided enough information about the problem. Any sugestions anyone has or if someone has encountred this problem before and knows of a fix would be much appreciated. 



0 Kudos
Message 1 of 4

Hi marsman2030,


One troubleshooting step for this would be to reset your COM ports.  Have you attempted to do this?


Additionally, what specific LabVIEW examples are you using?


Lastly, what version of VISA are you using?



0 Kudos
Message 2 of 4

Hi cblanchard,

Thanks for the reply!

I have tried resetting my com ports once. I reset them and will try connecting again later today.

I am running NI VISA 15.0. The siglent scope needs a minimum of 5.4 so I figure this should be okay, but I am going to double check this with Siglent as well.

I have mainly tried using the "Acquire Waveform" and the "Read Waveform (Single)" but I have tried several other configure examples just to see if I could get any communication at all and I had no luck there either.



0 Kudos
Message 3 of 4

Hi cblanchard,


The problem was the USB setting on the scope was not set correctly. Everything works as expected now.


Thank you for your help

0 Kudos
Message 4 of 4