LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview + Python = Runtime Error R6034

Highlighted

r6034.PNG

Each time I call a Python script from LabView the following error prompts. After pressing ok the python script runs without any problems and labview as well.

The LabView runtime engine is the 2018 32-bit, Python called is 2.7, Windows 10 64 bit

Do you know how to correct the error?

Thank you in advance!

0 Kudos
Message 1 of 6
(124 Views)

Hi cassaniti,

 

Just to initialize the troubleshooting and conversation here,

What was the order of installing - LabVIEW, Python?

Did you try reinstalling SW?

Was this the status from the beginning of trying calling Python script with LabVIEW, or it came after some update?
What is the version of Python (32vs64, patch version)

 

Hope this helps.

Regards,

Patrik
CTA, CLD
Helping (sharing) is caring!

If the post was helpful - Kudo it.
If the post answered your question - Mark it as Solution.
0 Kudos
Message 2 of 6
(80 Views)

Python 2.7 32 bit. Labview was updated last year from version 2015 to version 2018, python was installed somewhen in between. I didn't try to reinstall anything yet. Still trying to figure out what is wrong there...

0 Kudos
Message 3 of 6
(78 Views)

I assume you are using the Python node and not some other method of communicating with Python? Does this error occur regardless of what Python script you are running? Can you run the python examples that ship with LabVIEW, or do you get the same error there?

0 Kudos
Message 4 of 6
(72 Views)

Using the python node, it occours regardless of what python script I run. I will try with the python example shipped with Labview but I think that it happens with it too..

0 Kudos
Message 5 of 6
(48 Views)

If share your vi/snippet here, accordingly folks could give solution for that.

0 Kudos
Message 6 of 6
(45 Views)