LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview MathScript RT - problème de mémoire

Solved!
Go to solution

Bonjour a tous

J'ouvre un nouveau post car je rencontre un problème avec le module MathScript RT de NI.

Je souhaite afficher en 3D un image U32 (taille 1280 x 1024).

1min (ce qui me parait très long) après avoir lancé le VI, j'ai un problème de mémoire qui s'affiche (memory full) pourtant le gestionaire de tache indique 1.2GB pris par Labview.

J'aimerai savoir pourquoi j'ai ce problème. Est ce que ca vient de ma carte vidéo qui n'arrive pas a afficher l'image 3D ?

 

Merci d'avance

 

PC : dual core, 3GB de RAM.

J'utilise Windows XP 32bits et Labview 2010 SP1.

 

Pour info voici mon script (qui est très simple) :

figure
surf (imag)
title ('3D view')
xlabel ('width')
ylabel ('length')

0 Kudos
Message 1 of 6
(895 Views)

Bonjour,

Je ne parle pas français, seulement en anglais, cette réponse a été traduit en utilisant Google Translate donc je m'excuse si ce n'est pas facile à comprendre.

 

Quelles sont vos raisons d'utiliser MathScript dans LabVIEW?

 

De ma mémoire, la fonction de tracé de surface dans MatLab (qui simule MathScript) crée des définitions de nombreux Countour pour chaque couche z. Par conséquent, pour un ensemble de données très complexes mis l'intrigue résultante aura beaucoup de définitions Countour et ont donc besoin de beaucoup de mémoire. Il est fort possible que LabVIEW est à court de mémoire pour créer votre parcelle.

 

Avez-vous essayé d'utiliser les indigènes LabVIEW graphiques 3D de traçage? Vous pouvez rechercher la recherche d'exemples NI pour de bons exemples sur la façon de les utiliser.

Thoric (CLA, CLED, CTD and LabVIEW Champion)


0 Kudos
Message 2 of 6
(876 Views)

Hello Thoric

Sorry for this french post. Thank you for your quick answer. It's OK I understood your answer.

I have already used Graph 3D but I have met the same problem (RAM=1.2GB)  and graph 3D does not display.

please note my VI is atached

 

0 Kudos
Message 3 of 6
(862 Views)
Solution
Accepted by topic author eaglewatch86

I tried to load and work with your VI but the data set is simply too large. You'll probably need to reduce the sample size for plotting this in 3D, or consider working in LabVIEW 64-bit which might be able to handle large memory allocations better.

Thoric (CLA, CLED, CTD and LabVIEW Champion)


0 Kudos
Message 4 of 6
(855 Views)

Thank you Thoric for your help.

In conclusion my image is too large.  I'll work with LabVIEW 64bits.

0 Kudos
Message 5 of 6
(846 Views)

@eaglewatch86 wrote:

I'll work with LabVIEW 64bits.


There's no guarantee that will help, it was just a thought. I don't use 64 bit LabVIEW, but it ought to be worth a try Smiley Happy

Thoric (CLA, CLED, CTD and LabVIEW Champion)


0 Kudos
Message 6 of 6
(829 Views)