Showing results for 
Search instead for 
Did you mean: 

Labview Instaler now requiring "Z+ Virtual Control"


I am attempting to re-create an instaler for a project that i have been working on, and managed to do so a month ago. Since then, i worked on another unrelated project, during the course of which i had to instal drivers for a TDK Z+ power supply. This instalation included an utility executable VI named Z+ Virtual Control.


I am now working again on the first project, and i now cannot create the instaler, due to Labview requiring the "Z+ Virtual Control" as part of the source.

This project hold no dependency to the instr.lib/ZPlus/ folder, "Z+ Virtual Control" Isn't included in the source files of either the excutable or the instaler, and i didn't make any significant changes to the project.


I am at a loss to find why this is now required as part of my instalers.



I am using Labview 2014, the instaler include NI LabVIEW Runtime 2014 SP1 f3 ; NI-488.2 Runtime 14.0, and NI-VISA Runtime 14.0.1


Attempting to build a dummy project including only NI LabVIEW Runtime 2014 SP1 f3 seems to pass. Adding NI-488.2 Runtime 14.0 makes labview ask for "Z+ Virtual Control" again.

0 Kudos
Message 1 of 3

Did you tried Reinstalling of drivers for a TDK Z+ power supply again?

Palanivel Thiruvenkadam,
0 Kudos
Message 2 of 3

Hi Rfoxtrot,

Thank you for posting on the NI Forum.


I would like to ask you more information about your issue :

  1. What do you mean by not being able to create an installer ? Can you describe the procedure ? When is the blocking point ?
  2. Do you have any error code ? If so, can you upload a screenshot of it ?
  3. Do you have more information about the "VI named Z+ Virtual Control".
  4. Can you upload the project you for which you want to create an installer ?
  5. Did you try to create an installer of the wanted application before installing the "utility executable VI named Z+ Virtual Control" ?

Looking forward for your answer.


Best Regards,

0 Kudos
Message 3 of 3