LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview Icon Editor Freeze on Open

Hello NI community,

 

When I attempt to edit a VI icon within Labview 2020, the icon editor does not visually appear, but a frozen window appears when I ALT+TAB. I have no access to the editor, and no error message is displayed.

 

The VI is not opened anywhere else, and all files are located on a local drive (including my Labview Data directory). Moreover, I have Labview 2019 installed, and that can access the icon editor without worry.

 

I have completed the following steps with no success;

- Used the NI package manager to repair Labview 2020,

- Reinstalled Labview 2020.

 

Any help would be appreciated,

Thanks.

0 Kudos
Message 1 of 4
(203 Views)

Hi, may I confirm some details with you first?

  1. What method did you try to access icon editor? Double click on VI icon on upper left corner in front panel? Maybe you can try another method to open icon editor. You can refer this link for another method open icon editor: Icon Editor Dialog Box - LabVIEW 2018 Help - National Instruments (ni.com)
  2. Or when you click the icon editor, the labview not running and computer hang. Maybe some file directory is corrupted. Or can you check the C:\\..\Documents\Labview Data directory see if got any files missing? (if possible share some screenshot.) You can refer this link: Solved: Icon Editor - no templates, no glyphs - NI Community

If you face any difficulties during troubleshooting, we can discuss at here for next step.

0 Kudos
Message 2 of 4
(137 Views)

It could be that the VI is corrupted. Open a new VI and copy+paste the block diagram and see if it works better.

G# - Award winning reference based OOP for LV, for free! ADDQ VIPM Now on GitHub
"Only dead fish swim downstream" - "My life for Kudos!" - "Dumb people repeat old mistakes - smart ones create new ones."
Certified-LabVIEW-Developer
0 Kudos
Message 3 of 4
(118 Views)

Head over here:

 

https://forums.ni.com/t5/Enhanced-Icon-Editor/Icon-Editor-Source-Files-for-LabVIEW-2020/m-p/4042429#...

 

The linked post contains source code for the icon editor as well as instructions on how to replace the built-in icon editor.  Try that.  Just replacing it probably won't fix anything, but it's a start.

 

Once you've replaced it though, you can now add debug hooks, probes, etc into the icon editor code to narrow down what's causing the problem.  It does quite a lot of things on startup, and if you narrow it down to one node causing the problem it should give you a much better idea of where to look for a fix.

Message 4 of 4
(106 Views)