LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview 2015 (FPGA) Compilation is not successful (Labview 2010 to 2015 Conversion)

Hi Everybody,-

I was using Labview 2010 to program FPGA NI cRIO-9074 with IO modules AI- NI 9201 and AO- 9263 FPGA. I ve used FFT and scaled Window functions with FIFOs in 3 while loops and 1 Timed Loop. Everything was perfectly complied and I could see the results as I expected. Then I got Labview 2015, I formatted my hardware and installed software compatible for Labview 2015 and converted my program into Labview 2015 without any problem. But now when I m compiling the same porgram using 2015 compilation process will stop randomly some stage (Synthesizing or Place and Routing) and remains the position hours and hours without giving any error messages.

 

Does anybody experienced this before? Can somebody help me to overcome this problem?

 

Cheers

0 Kudos
Message 1 of 19
(1,416 Views)

I just complied the program with Labview 2010 keeping the Labview 2015 software on my FPGA and the FPGA target VI is compiling and running properly. Host VI is not working and it gives the error saying that software in the FPGA are not compatible with Labview 2010. Still the problem is with Labview 2015 I cannot compile the program.

0 Kudos
Message 2 of 19
(1,382 Views)

Hi farb, have you tried compiling on different servers?

\

0 Kudos
Message 3 of 19
(1,356 Views)

Yes I tried with local compile server and also with Compile Cloud service. But no successful compilation from both.

0 Kudos
Message 4 of 19
(1,348 Views)

Are you able to compile anything in 2015?

Matt J
National Instruments | CLA
0 Kudos
Message 5 of 19
(1,324 Views)

Yes. I could compile once or twice some small programs like AI read. This is how its look likes. No progress or error message after this.

 

Compile report

0 Kudos
Message 6 of 19
(1,300 Views)

Hey Farb16,

 

what do you meen with once or twice?

 

Greets,

Brandizzl

0 Kudos
Message 7 of 19
(1,290 Views)

I could successfully compile Labview 2015 FPGA programs without any error and it was working in runtime. I think if I write a another program, could still compile it without any problem.

0 Kudos
Message 8 of 19
(1,277 Views)

Based on the screenshot you posted, did you also update your PC to Windows 10? The Xilinx ISE 14.7 Compilation tools do not support Windows 10, and there have been a couple other reports of the tools hanging due to that on the forums here. I'd recommend trying a remote compile on the cloud: https://users.niwsc.com/compilecloud/#/.

Cheers!

TJ G
0 Kudos
Message 9 of 19
(1,251 Views)

Hi T-REX$

 

Exactly. I m using windows 10. But I tried also with cloud compiler service. Still I m getting the same result. Any Solution for this incompatibility? I mean is there any software or plug-in I can install on my System to get rid of this problem?

 

Anyway thanks for your reply.

 

Cheers

0 Kudos
Message 10 of 19
(1,238 Views)