LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview 2011 NI Report and error 7

Solved!
Go to solution
Highlighted

I know this topic has been cover in this forum many times, but I just can’t get it working.

 

Recently, we have updated our labview from 8.2 (Window XP) to 2011 sp1 (Window 7), and of course, NI report stops working.

In our software, we have a project that eventually gets compile into a DLL (Not AN .EXE, THIS IS NOT AN EXECUTABLE). In this DLL, we modify an excel spread sheet. As a result, we need the NI report tool kit.

Now I know that you would have to manually include the two folders (NIReport and LVclass)in your project in order for this to work in labview 2011, which I did by following the link below.

 

http://digital.ni.com/public.nsf/allkb/8A0E6274D9BD7B1986256F62006AD402?OpenDocument

 

I made sure that the two folders were “Always Included”, and not using the labview 8.x file layout. After the compiling has been complete, one DLL was created (with 4 other files, which is good because I only want one DLL). I assumed that the NI report tool kit is included in the build since I selected “Always included”.

After that I ran my main top level vi. The main top level vi tried to access the DLL, and I got error 7,

 

Get LV Class Default Value.vi<APPEND>

 

<b>Complete call chain:</b>

     Get LV Class Default Value.vi

     Test.vi

 

<b>LabVIEW attempted to load the class at this path:</b>

C:\BUILD PATH\DLL NAME.dll\1abvi3w\vi.lib\Utility\NIReport.llb\Excel\NI_Excel.lvclass

 

Now I assume this might be caused by two reasons. The path is incorrect or the tool kit wasn’t included.

I have been working on and off with this problem for weeks and still can’t get it working. I am guessing the path is incorrect, but I have manually changed the path to something different but got no luck. Any suggestions?

0 Kudos
Message 1 of 7
(2,196 Views)
Highlighted

"...and not using the labview 8.x file layout...."

 

 

If you want the most compatibility, go back and use the LabVIE 8.x file layout. The way paths to VIs is calculated changed in 2009. You will have to modify your code to make it work with the 2009 and above layout.

 

Here's the link to the article:

 

Error 7 

0 Kudos
Message 2 of 7
(2,174 Views)
Highlighted

Hi,

 

Thanks for the reply. 

 

The reason I didn't select "use Labview 8.x file layout" is because it will also create 10 extra support folders (I think this is due to name conflicts in the DLL directory) after compiling the project. This is not an acceptable solution for my customer since no one would want a DLL that comes with so many extra files.

And yes, I am aware of the file layout after Labview 2009. However, the path to NI_Excel.lvclass (C:\BUILD PATH\DLL NAME.dll\1abvi3w\vi.lib\Utility\NIReport.llb\Excel\NI_Excel.lvclass) was provided by “Excel class path.vi” (vi.lib\Utility\NIReport.llb\Excel class path.vi). In “excel class path.vi” it checks to see if the application is using the 8.x layout or not.

I switched to “use Labview 8.x file layout” just for testing reasons but it still doesn’t work. The file path for NI_Excel.lvclass is now C:\BUILD PATH\DLL NAME.dll\Excel\NI_Excel.lvclass (provided by “Excel class path.vi”). I also hard coded the path to C:\BUILD PATH\DLL NAME.dll\NI_Excel.lvclass and that doesn’t work too.

 

I have created a simple project to demonstrate my problem. Copy the attached folder to your desktop and you will see a folder named “Excel”. Open the “excel Test” project and build the DLL, check the build path and make sure it’s building to “Desktop\excel\Exceltest”. After that go to the DLL TEST folder (\Desktop\excel\DLL TEST) and run DLL test.vi. Make sure the path to the DLL (on the block diagram) is correct and run the vi. You should see the error I am talking about.

 

Thanks,

0 Kudos
Message 3 of 7
(2,162 Views)
Highlighted

Any suggestions? 

0 Kudos
Message 4 of 7
(2,128 Views)
Highlighted
Solution
Accepted by topic author benatoc

I finally fixed this problem.

 

I ended up creating my own Excel VIs (by copying the labview excel toolkit BIs) and included my VIs in my build.

 

Yes, it works.

 

No, this is not the best solution, but I don't even know if this problem can be fixed.

 

I don't know if this is considered a "labview bug" but if it is I sure hope someone in NI will fix it.

0 Kudos
Message 5 of 7
(1,970 Views)
Highlighted

Your fix seems to be one of two.  The other fix is the include the folder that contains the NI_Word.lvclass or the NI_Excel.lvclass in your project. Then insert it into the build making sure that the build points to the correct folder.  Neither is ideal, for sure.  I definately think this is an area where National Instruments needs to rectify.

Message 6 of 7
(1,441 Views)
Highlighted

I just encountered this same error. I manually added the NI_Excel.lvclass to my project and added it to the always include folder in build options and it seems to work.

Message 7 of 7
(1,342 Views)