LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Labview 2009 cannot read my Agilent multimeter

Hi! I want to use labview to read voltage from my Agilent 34450A multimeter. However, when I roll down the "Visa Resource Name" at the front panel, it does not read my multimeter, just "COM1". I know thought that the computer does read the multimeter. The Measurement & Automation Explorer does not recognize it, if that is what you are talking about. I am pretty sure the multimeter works fine, as I was able to read data through Agilent software. What can I do

0 Kudos
Message 1 of 16
(1,738 Views)

Go to MAX>>Tools>>VIS>>VISA Options

 

Select General settings Passports.  enable tulip support.

 

Look at the "Conflict manager page"  Select NI VIAS as the prefered VISA for the interface the Agilient shows up in.

 

(All of this is contained in the Agilient I/O Libraries documentation under "Using with NI"  or some heading like that

Scientists STAND on the shoulders of giants! They don't ride "piggyback" to keep their heads down.

"Should be" isn't "Is" -Jay
0 Kudos
Message 2 of 16
(1,733 Views)
There is no automatic method to detect what is connected to a serial port. The detection of the com port itself is all that you can expect. You don't have to do anything except to select the port for the resource name.
0 Kudos
Message 3 of 16
(1,730 Views)

The Agilent 34450a is connected to my computer via a USB port.

0 Kudos
Message 4 of 16
(1,718 Views)

The Agilent 34450a is connected to my computer via a USB port.

0 Kudos
Message 5 of 16
(1,717 Views)

It should be a USBTMC device not a com port

Scientists STAND on the shoulders of giants! They don't ride "piggyback" to keep their heads down.

"Should be" isn't "Is" -Jay
0 Kudos
Message 6 of 16
(1,705 Views)

But still why do I get only the COM1 option?  Shouldn't it give me a 34450A option?

0 Kudos
Message 7 of 16
(1,693 Views)

Do you have IVI and VISA installed?

If so, when you plug in the device windows will do the driver dance and you should end up with a "device installed successfully" balloon...

 

 

then in MAX, drop down "Devices and Interfaces" and look for your instrument there:

 

The VISA string is that long "USB0::" by default, but you can change that to something shorter/more recognizeable.

 

Drop down the "Software" tab in MAX and make sure you've got latest versions of IVI and VISA, then try it again.  Might need to go into Device Manager and reinstall the driver.

Download All
0 Kudos
Message 8 of 16
(1,684 Views)

OK Lets clarify some things.

 

That device is capable of USB, RS-232 and GPIB.  What interface is enabled?  You will need to go to the utility menu on the front panel.

 

OK you are connect to a USB port on your computer,  What are you connected to on the device? There are three communication interfaces available and each has the capability of being connected to a USB port through eithe a straght USB A-USB B cable or an appropiate adaptor.  Knowing this would let you find it in MAX since it may be exposed in three differernt places.

 

You said Agilient software communicates with the device.  Which agilient software.  I can think of four packages that would communicate with the instrument, (I/O Libraries config manager, Connection expert, Intuilink and the new one for DMMs)

Scientists STAND on the shoulders of giants! They don't ride "piggyback" to keep their heads down.

"Should be" isn't "Is" -Jay
0 Kudos
Message 9 of 16
(1,666 Views)

The problem is that MAX does not read the device.  What is the exact IVI and VISA that I should install?

0 Kudos
Message 10 of 16
(1,656 Views)