LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

LabView doesn't recognise COM ports

Highlighted

Hi,

 

I am trying to read the data sent by an Arduino via USB. Therefore, I have programmed a VI that is based on the VISA read function which works as intended on (almost) all computers. On the PC where the final system is supposed to run however, LabView doesn't recognise any COM ports, not only the Arduinos.

 

I have already read multiple forum threads concerning the issue of LabView not finding any COM ports and done the recommended steps. I have also tried reinstalling VISA. In NI MAX, no COM ports are shown. The devices and the COM ports do, however, show up in the Windows device manager. Also, I can successfully read the data sent by the Arduino via the Arduino IDE.

 

Is there a trick to make LabView recognise the COM ports? I am running LV2016 on Windows 10 - maybe there is some Windows setting that "blocks" LabView from recognising the ports?

 

Any help would be greatly appreciated - thanks in advance!

 

Greetings,

bkaiser

0 Kudos
Message 1 of 4
(1,317 Views)
Highlighted

Which version of NI VISA?

Do you use administrative user rights or are you resticted?

 

Norbert

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 2 of 4
(1,246 Views)
Highlighted

Hi Norbert_B,

 

thank you for your reply. I am using NI Visa 16 on a user account with full administrative privileges. I have already tried starting LabView in administrator mode, unfortunately with no success.

 

bkaiser

0 Kudos
Message 3 of 4
(1,240 Views)
Highlighted

Are you working with a virtual machine?

Are these COM ports external USB-Serial interfaces?

 

Norbert

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 4 of 4
(1,237 Views)